Contents

Chapter 1: The APL Environment .................................................. 1
Introduction .............................................................................. 1
APL Keyboards ......................................................................... 1
Session Manager ....................................................................... 4
Unicode Edition Keyboard ......................................................... 7
  Configuring the Dyalog APL IME ................................................ 8
Classic Edition Keyboard .......................................................... 11
Keyboard Shortcuts ..................................................................... 11
The Session Colour Scheme ......................................................... 17
The Session Window .................................................................. 19
Language Bar ............................................................................. 27
Entering and Executing Expressions ............................................ 29
Value Tips ................................................................................... 33
Array Editor ................................................................................ 37
The Session GUI Hierarchy .......................................................... 40
The Session MenuBar ................................................................. 41
Session Pop-Up Menu .................................................................. 55
The Session Toolbars ................................................................... 59
The Session Status Bar ............................................................... 64
Status Window .............................................................................. 66
The Workspace Explorer Tool ...................................................... 67
Browsing Classes ........................................................................ 77
Browsing Type Libraries ............................................................. 83
Browsing .NET Classes ............................................................... 94
Find Objects Tool ....................................................................... 103
Object Properties Dialog Box ...................................................... 106
The Editor .................................................................................... 111
Find and Replace Dialogs ............................................................ 146
Editing Scripts and Text Files ...................................................... 149
The Tracer .................................................................................... 153
The Threads Tool ......................................................................... 164
Debugging Threads ..................................................................... 168
The Event Viewer ......................................................................... 172
The Session Object ..................................................................... 180
  AfterFix ....................................................................................... 185
  Fix ................................................................................................. 186
  Format .......................................................................................... 187
  SessionPrint ................................................................................ 187
  SessionTrace ............................................................................... 189
  WorkspaceLoaded ........................................................................ 191
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuring the Session</td>
<td>192</td>
</tr>
<tr>
<td>Session Initialisation</td>
<td>197</td>
</tr>
<tr>
<td>User Commands</td>
<td>199</td>
</tr>
<tr>
<td>File Explorer Integration</td>
<td>200</td>
</tr>
<tr>
<td>File Associations</td>
<td>200</td>
</tr>
<tr>
<td>Browsing Workspaces and Source Files</td>
<td>200</td>
</tr>
</tbody>
</table>

**Index** .................................................................................. 205
Chapter 1:

The APL Environment

Introduction

The Dyalog APL Development Environment includes a Session Manager, an Editor, and a Tracer all of which operate in windows on the screen. The session window is created when you start APL and is present until you terminate your APL session. In addition there may be a number of edit and/or trace Windows, which are created and destroyed dynamically as required. All APL windows are under the control of Windows and may be selected, moved, resized, maximised and minimised using the standard facilities that Windows provides.

APL Keyboards

The Classic and Unicode Editions of Dyalog APL for Windows use different techniques for mapping keystrokes to APL characters and to special command shortcuts.

The Classic Edition uses a proprietary technique for these mappings.

By default, the Unicode Edition uses Microsoft's IME (Input Method Editor) technology. Many other applications use the same technology, which means that the Dyalog Unicode IME may be used not only with Dyalog APL for Windows Unicode Edition, but also with word processing applications, spreadsheets, terminal emulators etc. Therefore with the Dyalog Unicode IME installed, and with a suitable font selected, APL characters can be entered and viewed in many other applications.

As an alternative to the Dyalog Unicode IME, whose installation requires Administrator privileges, the key mapping for the Unicode Edition may be specified in the Windows registry. See Unicode Edition and the Registry Keyboard on page 3.

In both Classic and Unicode Editions APL characters are generated when the user presses certain combinations of meta keys in conjunction with the normal character keys. Meta keys include Shift, Ctrl and Alt.
For both input techniques it is possible to alter the mapping of keystrokes to APL characters, and to add support for new languages. It is also possible to alter the keystrokes which define special command keyboard shortcuts. For further details, see *Unicode Edition Keyboard on page 7* or *Classic Edition Keyboard on page 11*.

**Unicode Edition and the Dyalog Unicode IME**

The Dyalog Unicode IME is the default input mechanism for generating APL characters for Unicode editions of Dyalog APL. The version of the IME supplied with version 18.2 can be used with version 12.1 and later, provided that they are patched to a version created on or after 1st April 2011.

The Dyalog Unicode IME defines the mapping of keystrokes to Unicode characters. Only keystrokes which resolve to characters that either do not appear on the standard keyboard or which differ from those that appear on the standard keyboard are included in the selectable translate table. In effect the Dyalog Unicode IME can be regarded as an overlay of the standard keyboard which contains just APL characters.

The Dyalog Unicode IME supplied with Version 18.2 includes support for Belgian, Danish, Finnish, French, German, Italian, Spanish, Swedish and British and American English keyboards, based on the Dyalog hardware keyboard layout; these keyboard layouts are described at https://dfns.dyalog.com/n_keyboards.htm. Note that for Danish, British and American English keyboards the older layouts, based on the Dyalog APL Ctrl Keyboard, are included in the UnicodeIME\aplkeys directory.

The default keyboard mapping for unsupported languages is American English.

The IME translate tables include mappings for the special command keystrokes used by Dyalog APL.

These command keystroke mappings are ignored by applications unless the application is explicitly named in the Dyalog Unicode IME configuration. It is expected that only terminal emulators used for running UNIX-based versions of Dyalog APL will use this feature.

In particular, Dyalog APL for Windows Unicode Edition does not use the mappings in the translate tables; the mappings are defined under Options/Configure/Keyboard Shortcuts (see *Installation & Configuration Guide: Configuration Dialog: Keyboard Shortcut Tab*).

Note that the Dyalog Unicode IME replaces any previous IME, as well as the Dyalog Ctrl and Dyalog AltGr keyboards.
Unicode Edition and the Registry Keyboard

The Registry Keyboard provides an alternative mechanism for the Unicode Edition. This feature maps keystrokes to APL characters using entries in the Windows Registry. Dyalog supports the mechanism but does not provide the mappings which must therefore be defined by the user.

Note that the Dyalog IME is used if it is available; the Registry Keyboard mechanism is used only if the Dyalog IME is not installed.

The mappings are defined in the Registry sub-folder:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Dyalog\Dyalog APL/W-64 18.2 Unicode\KeyboardShortcuts\chars

Each entry consists of the Unicode code point of an APL character followed by the keystroke to which it is mapped.

The keystroke is defined by 4 hexadecimal values which specify the key, the shift-state, and 2 zeros. The key is represented by the Unicode code point of the symbol engraved upon it, so (on a UK keyboard) the <1> key is hex 31 and the <A> key is hex 41. The Shift-states values are the sum of 1 (Shift), 2 (Ctrl), 4 (Alt).

"0x230A"=hex:44,02,00,00
"0x235F"=hex:38,03,00,00

In the first entry, the APL character is Unicode code point 230A which is ⌊. The key is <D> (hex 44) and the shift-state is Ctrl (hex 02).

In the second entry, the APL character is Unicode code point 235F which is ⍟. The character is entered by pressing <*> (hex 38) with Shift+Ctrl (hex 03).

Classic Edition

The mapping for each of the ⎕AV positions and its associated keystroke is defined by a selectable translate table. ⎕AV includes all the APL symbols used by Dyalog APL as well as all the (non-APL) characters which appear on a standard keyboard. This mapping only works with Classic Edition.

The Classic Edition installation also includes the Dyalog Unicode IME (described below) so that users may enter APL characters into other applications; the Dyalog Unicode IME is however not used by the Classic Edition itself.

The Classic Edition includes support for Danish, Finnish, French, German, Italian, Swedish, and both British and American English keyboards. The default keyboard mapping for unsupported languages is American English.

Backtick Keyboard

In addition to the standard APL keyboards, the RIDE keyboard may be used natively. See Backtick Keyboard on page 9.
Session Manager

The Dyalog APL/W session is fully configurable. Not only can you change the appearance of the menus, tool bars and status bars, but you can add new objects of your choice and attach your own APL functions and expressions to them. Functions and variables can be stored in the session namespace. This is independent of the active workspace; so there is no conflict with workspace names, and your utilities remain permanently accessible for the duration of the session. Finally, you may set up different session configurations for different purposes which can be saved and loaded as required.

The session window is defined by an object called ⎕SE. This is very similar to a Form object, but has certain special properties. The menu bar, tool bar and status bars on the session window are in fact MenuBar, ToolControl and StatusBar objects owned by ⎕SE. All of the other components such as menu items and tool buttons are also standard GUI objects. You may use ⎕WC to create new session objects and you may use ⎕WS to change the properties of existing ones. ⎕WG and ⎕WN may also be used with ⎕SE and its children.

Components of the session that perform actions (Menuitem and Button objects) do so because their Event properties are defined to execute system operations or APL expressions. System operations comprise a pre-defined set of actions that can be performed by Dyalog APL/W. These are coded as keywords within square brackets. For example, the system operation [WSClear] produces a clear ws, after first displaying a dialog box for confirmation. You may customise your session by adding or deleting objects and by attaching system operations or APL expressions to them.

Like any other object, ⎕SE is a namespace that may contain functions and variables. Furthermore, ⎕SE is independent of the active workspace and is unaffected by )LOAD and )CLEAR. It is therefore sensible to store commonly used utilities, particularly those utilities that are invoked by events on session objects, in ⎕SE itself, rather than in each of your application workspaces.

The possibility of configuring your APL session so extensively leads to the requirement to have different sessions for different purposes. To meet this need, sessions are stored in special files with a .DSE (Dyalog Session) extension. The default session (i.e. the one loaded when you start APL) is specified by the session_file parameter. You may customise this session and then save it over the default one or in a separate file. You can load a new session from file at any stage without affecting your active workspace.
Positioning the Cursor

The cursor may be positioned within the current APL window by moving the mouse pointer to the desired location and then clicking the Left Button. The APL cursor will then move to the character under the pointer.

Selection

Dragging the mouse selects the text from the point where the mouse button is depressed to the point where the button is released. When you select multiple lines, the use of the left mouse button always selects text from the start of the line. A contiguous block of text can be selected by dragging with the right mouse button.

Double-clicking the left mouse button to the left of a line selects the whole line, including the end-of-line character.

Scrolling

Data can be scrolled in a window using the mouse in conjunction with the scrollbar.

Invoking the Editor

The Editor can be invoked by placing the mouse pointer over the name of an editable object and double-clicking the left button on the mouse. If you double-click on the empty Input Line it acts as "Naked Edit" and opens an edit window for the suspended function (if any) on the APL stack. For further details, see Invoking the Editor on page 111. See also "Installation and Configuration Guide: DoubleClickEdit".

The Current Object

If you position the input cursor over the name of an object in the session window, that object becomes the current object. This name is stored in the CurObj property of the Session object and may be used by an application or a utility program. This means that you can click the mouse over a name and then select a menu item or click a button that executes code that accesses the name.

The Session Pop-up Menu

Clicking the right mouse button brings up the Session pop-up menu. This is described later in this chapter.
Drag-and-Drop Editing

Drag-and-Drop editing is the easiest way to move or copy a selection a short distance within an edit window or between edit windows.

To move text using drag-and-drop editing:

1. Select the text you want to move.
2. Point to the selected text and then press and hold down the left mouse button. When the drag-and-drop pointer appears, drag the cursor to a new location.
3. Release the mouse button to drop the text into place.

To copy text using drag-and-drop editing:

1. Select the text you want to move.
2. Hold down the Ctrl key, point to the selected text and then press and hold down the left mouse button. When the drag-and-drop pointer appears, drag the cursor to a new location.
3. Release the mouse button to drop the text into place.

If you drag-and-drop text within the Session window, the text is copied and not moved whether or not you use the Ctrl key.

Interrupts

To generate an interrupt, click on the Dyalog APL icon in the Windows System Tray; then choose Weak Interrupt or Strong Interrupt. To close the menu, click Cancel. Alternatively, to generate a weak interrupt, press Ctrl+Break, or select Interrupt from the Action menu on the Session Window.
Unicode Edition Keyboard

Introduction

Unicode Edition supports the use of standard Windows keyboards that have the additional capability to generate APL characters when the user presses Ctrl, Alt, AltGr (or some other combination of meta keys) in combination with the normal character keys.

Dyalog APL is supplied with the Dyalog Unicode IME keyboard for a range of different languages as listed below. The intention is that only APL characters and characters that appear in locations different from the underlying keyboard are defined; any other keystroke is passed through as is.

Installation

During the Installation of Dyalog APL Unicode Edition, setup installs the Dyalog Unicode IME (IME). For any given Input Language the IME consists of an additional service for that Input Language, and a translate table which maps keystrokes for the appropriate keyboard to Unicode code points for APL characters.

An IME service is installed for every Input Language that the user who installs Dyalog APL has defined, as well as every Input Language for which Dyalog has support.

The keyboard mappings are defined for the following national languages: Belgian, Danish, Finnish, French, German, Italian, Spanish, Swedish and British and American English.

These mappings are described at https://dfns.dyalog.com/n_keyboards.htm.

For any other Input Language the American English translate table is selected. Note that some Input Languages are defined to be substitutes for other Input Languages; for example Australian English Input is a substitute for American English Input, Austrian German Input a substitute for German German Input. In these cases the IME will install the appropriate translate table. It is also possible to create support for new languages or to modify the existing support. See the IME User Guide for further details.
Configuring the Dyalog APL IME

The Dyalog Unicode IME is added as an additional service to all keyboards defined to the user and the administrator at the time that the IME was installed.

For each IME the underlying keyboard layout file will be the same as that defined for the base keyboard. The layout file is a DLL created by Microsoft.

The language specified in the description of the IME is the name of the IME translate table that has been associated with the IME for the specific keyboard. In the case of languages not supported by the IME the keyboard will default to en-US.

IME Properties

To change the properties of the IME go to Options/Configure/Unicode Input tab and select Configure Layout:
Input translate table:

The translate table defines the mapping between APL characters and the keystrokes that generate those APL characters. It is possible to alter the mapping or to create support for new keyboards by altering the translate table, or by selecting a different translate table. See the IME User Guide for more details.

Backtick Keyboard

The Backtick keyboard provided by the RIDE may be used natively. By default it is disabled. To enable it, check the box labelled Enable Backtick Keyboard introducer. You may replace the backtick character (`) with an alternative character to act as the introducer for APL glyphs, but take care to choose a character that is otherwise unused.

For information on using this keyboard interface, see RIDE User Guide.
Overstrikes:

In the original implementations of APL, many of the special symbols could only be generated by overstriking one character on top of another as is reflected in the appearance of the glyphs. For example, the symbol for Grade Up (⍋) is actually the symbol for delta (∆) superimposed on the symbol for vertical bar (|)

In Dyalog APL such symbols can be generated either by a single keystroke, or (in Replace mode) by overtyping one symbol with another. For example ⌈ may be generated using Shift+Ctrl+4, or by switching to Replace mode and typing the three keystrokes Ctrl+h, Left-Cursor, Ctrl+m.

Using the Dyalog Unicode IME the character can also be entered by pressing Ctrl+Bksp, Ctrl+m, Ctrl+h. Note that Ctrl+Bksp is the default Overstrike Introducer Key (key code OS).

Use Overstrike popup:

With this option selected, when the character following the Overstrike Introducer Key is pressed, a popup box displays all the overstrikes which contain the last character typed: in the example below Ctrl+Bksp has been followed by Ctrl+h:

![Overstrike Popup](image)

Note the fine (red) line under the ∆. This indicates that an overstrike creation operation is in progress.

The input of the symbol ⌈ can be completed by pressing Ctrl+m, or by moving the selection up and down the pop-up list using Cursor-Up or Cursor-Down.

Overstrikes do not require the OS introducer key:

With this option selected, the IME identifies characters which are part of a valid overstrike, and when such a character is entered into the session, begins an overstrike creation operation.
Chapter 1: The APL Environment

Classic Edition Keyboard

The standard Classic Edition keyboard tables are files supplied in the aplkeys sub-directory named cc.din where cc is the standard 2-character country code, e.g. uk.din.

Note that the standard tables do not support the entry of APL underscored characters AABCDEFHIJKLMNOPQRSTUVWXYZ.

The standard table supports two modes of use; traditional (mode 0) and unified (mode 1). The keyboard starts in mode 1 and may be switched between modes by clicking the Uni/Apl field in the status bar or by keying * on the Numeric-Keypad.

The Classic Edition keyboard layout is close to that of the Unicode Edition, but does not include certain symbols which are only provided in the Unicode Edition.

Keyboard Shortcuts

The terms keyboard shortcut (Unicode Edition) and command (Classic Edition) are used herein to describe a keystroke that generates an action, rather than one that produces a symbol.

Unicode Edition

Unicode Edition provides a number of shortcut keys that may be used to perform actions. For compatibility with Classic Edition and with previous Versions of Dyalog APL, these are identified by 2-character codes; for example the action to start the Tracer is identified by the code <TC>, and mapped to user-configurable keystrokes.

In the Unicode Edition, Keyboard Shortcuts are defined using Options/Configure/Keyboard Shortcuts and stored in the Windows Registry. Note that the Unicode IME translate tables have definitions for the Keyboard Shortcuts too; these are ignored by the interpreter, and are intended for use with terminal emulators being used in conjunction with non-GUI versions of Dyalog APL.

To the right of the last symbol in the Language Bar is the Keyboard Shortcut icon 📋. If you hover the mouse over this icon, a pop-up tip is displayed to remind you of your keyboard shortcuts as illustrated below.
Chapter 1: The APL Environment

Keyboard Shortcuts

- Quit (end case changes): Shift+Esc
- Tab between windows: (None)
- Back tab between windows: (None)
- Exit (end save changes): Esc
- Right screen: (None)
- Left screen: (None)
- Scroll to current line: (None)
- Cut: (None)
- Copy: (None)
- Paste: (None)
- Reformat: Num divide
- Delete block: Control+Delete
- Forward or Back: Control+Shift+Enter
- Backward or Undo: Control+Shift+Back
- Search: (None)
- Replace: (None)
- Next: (None)
- Previous: (None)
- Edit: (None)
- T: Trace: Control+Enter
- F: Fix the current function: (None)
- JK: Toggle line numbers: Num -
- JF: Jump between current window and session window: (None)
- R: Run to exit (in tracer): (None)
- BF: Toggle breakpoint: (None)
- NH: Continue execution of all threads: (None)
- TL: Toggle localization: Control+Up
- UA: Undo all changes: (None)
- AD: Comment out selected lines: (None)
- DD: Uncomment selected lines: (None)
- GL: Go to line: (None)
- SA: Select all: (None)
- AC: Align Comments: (None)
- MK: Unpause all paused threads: (None)
- OF: Open file in editor: (None)
- FS: Save file as A in editor: (None)
- SE: Save file in editor: (None)
- ST: Toggle the tree view in the editor: (None)
- CY: Cycle focus around edit windows: (None)
- PL: Go back to previous location: (None)
- TD: Toggle outline: (None)
- MO: Data matching outline: (None)
- SI: Fix script and exit editor: (None)
- S2: Script but remain in editor: (None)
- CE: Out to capsule: (None)
- IL: Insert line under cursor: (None)
- EL: Empties the line under cursor: (None)
Chapter 1: The APL Environment

Classic Edition

Commands fall into four categories, namely cursor movement, selection, editing directives and special operations, and are summarised in the following tables. The input codes in the first column of the tables are the codes by which the commands are identified in the Input Translate Table.

Table 1: Cursor Movement Commands

<table>
<thead>
<tr>
<th>Input Code</th>
<th>Keystroke</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LS</td>
<td>Ctrl+PgUp</td>
<td>Scrolls left by a page</td>
</tr>
<tr>
<td>RS</td>
<td>Ctrl+PgDn</td>
<td>Scrolls right by a page</td>
</tr>
<tr>
<td>US</td>
<td>PgUp</td>
<td>Scrolls up by a page</td>
</tr>
<tr>
<td>DS</td>
<td>PgDn</td>
<td>Scrolls down by a page</td>
</tr>
<tr>
<td>LC</td>
<td>Left Arrow</td>
<td>Moves the cursor one character position to the left</td>
</tr>
<tr>
<td>RC</td>
<td>Right Arrow</td>
<td>Moves the cursor one character position to the right</td>
</tr>
<tr>
<td>DC</td>
<td>Down Arrow</td>
<td>Moves the cursor to the current character position on the line below the current line</td>
</tr>
<tr>
<td>UC</td>
<td>Up Arrow</td>
<td>Moves the cursor to the current character position on the line above the current line</td>
</tr>
<tr>
<td>UL</td>
<td>Ctrl+Home</td>
<td>Move the cursor to the top-left position in the window</td>
</tr>
<tr>
<td>DL</td>
<td>Ctrl+End</td>
<td>Moves the cursor to the bottom-right position in the window</td>
</tr>
<tr>
<td>RL</td>
<td>End</td>
<td>Moves the cursor to the end of the current line</td>
</tr>
<tr>
<td>LL</td>
<td>Home</td>
<td>Moves the cursor to the beginning of the current line</td>
</tr>
<tr>
<td>LW</td>
<td>Ctrl+Left Arrow</td>
<td>Moves the cursor to the beginning of the word to the left of the cursor</td>
</tr>
<tr>
<td>RW</td>
<td>Ctrl+Right Arrow</td>
<td>Moves the cursor to the end of the word to the right of the cursor</td>
</tr>
<tr>
<td>TB</td>
<td>Ctrl+Tab</td>
<td>Switches to the next session/edit/trace window</td>
</tr>
<tr>
<td>BT</td>
<td>Ctrl+Shift+Tab</td>
<td>Switches to the previous session/edit/trace window</td>
</tr>
</tbody>
</table>
Table 2: Selection Commands

<table>
<thead>
<tr>
<th>Input Code</th>
<th>Keystroke</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lc</td>
<td>Shift+Left Arrow</td>
<td>Extends the selection one character position to the left</td>
</tr>
<tr>
<td>Rc</td>
<td>Shift+Right Arrow</td>
<td>Extends the selection one character position to the right</td>
</tr>
<tr>
<td>Lw</td>
<td>Ctrl+Shift+Left Arrow</td>
<td>Extends the selection to the beginning of the word to the left of the cursor</td>
</tr>
<tr>
<td>Rw</td>
<td>Ctrl+Shift+Right Arrow</td>
<td>Extends the selection to the end of the word to the right of the cursor</td>
</tr>
<tr>
<td>Uc</td>
<td>Shift+Up Arrow</td>
<td>Extends the selection to the current character position on the line above the current line</td>
</tr>
<tr>
<td>Dc</td>
<td>Shift+Down Arrow</td>
<td>Extends the selection to the current character position on the line below the current line</td>
</tr>
<tr>
<td>Ll</td>
<td>Shift+Home</td>
<td>Extends the selection to the beginning of the current line</td>
</tr>
<tr>
<td>Rl</td>
<td>Shift+End</td>
<td>Extends the selection to the end of the current line</td>
</tr>
<tr>
<td>Ul</td>
<td>Ctrl+Shift+Home</td>
<td>Extends the selection to the beginning of the first line in the window</td>
</tr>
<tr>
<td>Dl</td>
<td>Ctrl+Shift+End</td>
<td>Extends the selection to the end of the last line in the window</td>
</tr>
<tr>
<td>Us</td>
<td>Shift+PgUp</td>
<td>Extends the selection up by a page</td>
</tr>
<tr>
<td>Ds</td>
<td>Shift+PgDn</td>
<td>Extends the selection down by a page</td>
</tr>
</tbody>
</table>
### Table 3: Editing Directives

<table>
<thead>
<tr>
<th>Input Code</th>
<th>Keystroke</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DI</td>
<td>Delete</td>
<td>Deletes the selection</td>
</tr>
<tr>
<td>DK</td>
<td>Ctrl+Delete</td>
<td>Deletes the current line in an Edit window. Deletes selected lines in the Session Log</td>
</tr>
<tr>
<td>CT</td>
<td>Shift+Delete</td>
<td>Removes the selection and copies it to the clipboard</td>
</tr>
<tr>
<td>CP</td>
<td>Ctrl+Insert</td>
<td>Copies the selection into the clipboard</td>
</tr>
<tr>
<td>FD</td>
<td>Ctrl+Shift+Enter</td>
<td>Reapplies the most recent undo operation</td>
</tr>
<tr>
<td>BK</td>
<td>Ctrl+Shift+Bksp</td>
<td>Performs an undo operation</td>
</tr>
<tr>
<td>PT</td>
<td>Shift+Insert</td>
<td>Copies the contents of the clipboard into a window at the location selected</td>
</tr>
<tr>
<td>OP</td>
<td>Ctrl+Shift+Insert</td>
<td>Inserts a blank line immediately after the current one (editor only)</td>
</tr>
<tr>
<td>HT</td>
<td>Tab</td>
<td>Indents text</td>
</tr>
<tr>
<td>TH</td>
<td>Shift+Tab</td>
<td>Removes indentation</td>
</tr>
<tr>
<td>RD</td>
<td>Keypad-slash</td>
<td>Reformats a function (editor only)</td>
</tr>
<tr>
<td>TL</td>
<td>Ctrl+Alt+L</td>
<td>Toggles localisation of the current name</td>
</tr>
<tr>
<td>GL</td>
<td>Ctrl+Alt+G</td>
<td>Go to [line]</td>
</tr>
<tr>
<td>AO</td>
<td>Ctrl+Alt+,</td>
<td>Add Comments</td>
</tr>
<tr>
<td>DO</td>
<td>Ctrl+Alt+.</td>
<td>Delete Comments</td>
</tr>
<tr>
<td>AC</td>
<td></td>
<td>Align Comments</td>
</tr>
</tbody>
</table>
### Table 4: Special Operations

<table>
<thead>
<tr>
<th>Input Code</th>
<th>Keystroke</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IN</td>
<td>Insert</td>
<td>Insert on/off</td>
</tr>
<tr>
<td>LN</td>
<td>Keypad-minus</td>
<td>Line numbers on/off</td>
</tr>
<tr>
<td>ER</td>
<td>Enter</td>
<td>Execute</td>
</tr>
<tr>
<td>ED</td>
<td>Shift+Enter</td>
<td>Edit</td>
</tr>
<tr>
<td>TC</td>
<td>Ctrl+Enter</td>
<td>Trace</td>
</tr>
<tr>
<td>EP</td>
<td>Esc</td>
<td>Exit</td>
</tr>
<tr>
<td>QT</td>
<td>Shift+Esc</td>
<td>Quit</td>
</tr>
</tbody>
</table>
The Session Colour Scheme

Within the Development Environment, different colours are used to identify different types of information. These colours are normally defined by registry entries and may be changed using the Colour Configuration dialog box as described later in this chapter.

In the Classic Edition, colours may alternatively be defined in the Output Translate Table (normally WIN.DOT). This table recognises up to 256 foreground and 256 background colours which are referenced by colour indices 0-255. These colour indices are mapped to physical colours in terms of their Red, Green and Blue intensities (also 0-255). Foreground and background colours are specified independently as Cnnn or Bnnn. For example, the following entry in the Output Translate Table defines colour 250 to be red on magenta.

- C250: 255 0 0 + Red foreground
- B250: 255 0 255 + Magenta background

The first table below shows the colours used for different session components. The second table shows how different colours are used to identify different types of data in edit windows.

<table>
<thead>
<tr>
<th>Colour</th>
<th>Used for</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>249</td>
<td>Input and marked lines</td>
<td>Red on White</td>
</tr>
<tr>
<td>250</td>
<td>Session log</td>
<td>Black on White</td>
</tr>
<tr>
<td>252</td>
<td>Tracer : Suspended Function</td>
<td>Yellow on Black</td>
</tr>
<tr>
<td>253</td>
<td>Tracer : Pendent Function</td>
<td>Yellow on Dark Grey</td>
</tr>
<tr>
<td>245</td>
<td>Tracer : Current Line</td>
<td>White on Red</td>
</tr>
</tbody>
</table>
Table 6: Default Colour Scheme Edit windows

<table>
<thead>
<tr>
<th>Colour</th>
<th>Array Type</th>
<th>Editable</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>236</td>
<td>Simple character matrix</td>
<td>Yes</td>
<td>Green on Black</td>
</tr>
<tr>
<td>239</td>
<td>Simple numeric</td>
<td>No</td>
<td>White on Dk Grey</td>
</tr>
<tr>
<td>241</td>
<td>Simple mixed</td>
<td>No</td>
<td>Cyan on Dk Grey</td>
</tr>
<tr>
<td>242</td>
<td>Character vector of vectors</td>
<td>Yes</td>
<td>Cyan on Black</td>
</tr>
<tr>
<td>243</td>
<td>Nested array</td>
<td>No</td>
<td>Cyan on Dk Grey</td>
</tr>
<tr>
<td>245</td>
<td>⊤OR object</td>
<td>No</td>
<td>White on Red</td>
</tr>
<tr>
<td>248</td>
<td>Function or Operator</td>
<td>No</td>
<td>White on Dk Cyan</td>
</tr>
<tr>
<td>254</td>
<td>Function or Operator</td>
<td>Yes</td>
<td>White on Blue</td>
</tr>
</tbody>
</table>

Syntax Colouring in the Session

As an adjunct to the overall Session Colour Scheme, you may choose to apply a syntax colouring scheme to the current Session Input line(s). You may also extend syntax colouring to previously entered input lines, although this only applies to input lines in the current session; syntax colouring information is not remembered in the Session Log.

Syntax colouring may be used to highlight the context of names and other elements when the line was entered. For example, you can identify global names and local names by allocating them different colours.

The Session Window

The primary purpose of the session window is to provide a scrolling area within which you may enter APL expressions and view results. This area is described as the session log. Normally, the session window will have a menu bar at the top with a tool bar below it. At the bottom of the session window is a status bar. However, these components of the session may be extensively customised and, although this chapter describes a typical session layout, your own session may look distinctly different. A typical Session is illustrated below.

A typical Session window
Window Management

When you start APL, the session is loaded from the file specified by the session_file parameter. The position and size of the session window are defined by the Posn and Size properties of the Session object ⍴SE, which will be as they were when the session file was last saved.¹

The name of the active workspace is shown in the title bar of the window, and changes if you rename the workspace or )LOAD another.

You can move, resize, minimise or maximise the Session Window using the standard Windows facilities.

In addition to the Session Window itself, there are various subsidiary windows which are described later in the Chapter. In general, these subsidiary windows may be docked inside the Session window, or may be stand-alone floating windows. You may dock and undock these windows as required. The standard Session layout illustrated above, contains docked Editor, Tracer and SIStack windows.

Note that the session window is only displayed when it is required, i.e. when APL requests input from or output to the session. This means that end-user applications that do not interact with the user through the session will not have an APL session window.

¹In a Windows shortcut to an application, the Run: state may be one of "Normal window", "Minimised" and "Maximised". There are other states which can be set when a process is spawned. If the Run: state is Normal or Default, Dyalog APL will use the settings in the current session file to determine the state and size of the session on startup; for all other states (including Maximised and Minimised) these states will be used, superceding the settings in the current session file.
Docking

Nearly all of the windows used in the Dyalog APL IDE may be docked in the Session window or be stand-alone floating windows. When windows are docked in the Session, the Session window is split into resizable panes, separated by splitters. The following example, using the Status window, illustrates the principles involved. (The use of the Status window is described later in this Chapter.)

To start with, the Status window is hidden. You may display it by selecting the Status menu item from the Tools menu. It initially appears as a floating (undocked) window as shown below.
If you press the left mouse button down over the Status window title bar, and drag it, you will find that when the mouse pointer is close to an edge of the Session window, the drag rectangle indicates a docking zone as shown below. This indicates the space that the window will occupy if you now release the mouse button to dock it.
The next picture shows the result of the docking operation. The Session window is now split into 2 panes, with the Status window in the upper pane and the Session log window in the lower pane. You can resize the panes by dragging with the mouse.

You will notice that a docked window has a title bar (in this case, the caption is \textit{Status}) and 3 buttons which are used to \textit{Minimise}, \textit{Maximise} and \textit{Close} the docked window.
The next picture shows the result of minimising the Status window pane. All that remains of it is its title bar. The Minimise button has changed to a Restore button, which is used to restore the pane to its original size.
You can pick up a docked window and then re-dock it along a different edge of the Session as illustrated below.

Docking the Status window along the left edge of the Session causes the Session window to be split into two vertical panes. Notice how the title bar is now drawn vertically.
If you click the right mouse button over any window, its context menu is displayed. If the window is dockable, the context menu contains the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Undock</strong></td>
<td>Undocks the docked window. The window is displayed at whatever position and size it occupied prior to being docked</td>
</tr>
<tr>
<td><strong>Hide Caption</strong></td>
<td>Hides the title bar of the docked window</td>
</tr>
<tr>
<td><strong>Dockable</strong></td>
<td>Specifies whether the window is currently dockable or is locked in its current state. You can use this to prevent the window from being docked or undocked accidentally</td>
</tr>
</tbody>
</table>

The last picture shows the effect of using Hide Caption to remove the title bar. In this state, you can resize the pane with the mouse, but the Minimise, Maximise and Close buttons are not available. However, you can restore the object's title bar using its context menu.
Language Bar

The Language Bar is an optional window which is initially docked to the Session Window, to make it easy to pick APL symbols without using the keyboard.

If you hover the mouse pointer over a symbol in the Language Bar, a pop-up tip is displayed to remind you of its usage. If you click on a symbol in the Language Bar, that symbol is inserted at the cursor in the current line in the Session.
Popup Menu

If you click the right mouse button in the Language Bar, the context menu displays the following options:

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Space Before</td>
<td>Inserts a blank space before the current symbol (or blank)</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the current symbol (or blank)</td>
</tr>
<tr>
<td>Help</td>
<td>Displays the (F1) help topic for the current symbol.</td>
</tr>
<tr>
<td>Use the Session font</td>
<td>Displays the symbols using the current Session font (by default the symbols are displayed using a small font)</td>
</tr>
<tr>
<td>Revert to defaults</td>
<td>Removes all user customisation and reverts to the standard Language Bar.</td>
</tr>
</tbody>
</table>
Chapter 1: The APL Environment

Entering and Executing Expressions

Introduction

The session contains the *input line* and the *session log*. The input line is the last line in the session, and is (normally) the line into which you type an expression to be evaluated.

The session log is a history of previously entered expressions and the results they produced.

If you are using a log file, the Session log is loaded into memory when APL is started from the file specified by the **log_file** parameter. When you close your APL session, the Session log is written back out to the log file, replacing its previous contents.

In general you type an expression into the input line, then press Enter (ER) to run it. After execution, the expression and any displayed results become part of the session log.

You can move around in the session using the scrollbar, the cursor keys, and the PgUp and PgDn keys. In addition, Ctrl+Home (UL) moves the cursor to the beginning of the top-line in the Log and Ctrl+End (DL) moves the cursor to the end of the last (i.e. the *current*) line in the session log. Home (LL) and End (RL) move the cursor to the beginning and end respectively of the line containing the cursor.

Deleting Lines

You may delete one or more lines from the Session using the DK command (Ctrl+Delete). This action removes the current line or the selected block of lines from the Session window and from the Session log. The removal is permanent and you will be prompted to confirm:
Auto Complete

As you start to enter characters in an APL expression, the Auto Complete suggestions pop-up window (AC for short) offers you a choice based upon the characters you have already entered and the current context.

For example, if you enter a ⍝, AC displays a list of all the system functions and variables. If you then enter the character r, the list shrinks to those system functions and variables beginning with the letter r, namely refs, rtl, rsi, and rtl. Instead of entering the remaining characters, you may select the appropriate choice in the AC list. This is done by pressing the right cursor key.

If you begin to enter a name, AC will display a list of namespaces, variables, functions, operators that are defined in the current namespace. If you are editing a function, AC will also include names that are localised in the function header.

If the current space is a GUI namespace, the list will also include Properties, Events and Methods exposed by that object.

As an additional refinement, AC remembers a certain number of previous auto complete operations, and uses this information to highlight the most recent choice you made.

For example, suppose that you enter the two characters )c. AC offers you )clear thru )cs, and you choose )cs from the list. The next time you enter the two characters )c, AC displays the same list of choices, but this time )cs is pre-selected.

You can disable or customise Auto Completion from the Auto Complete page in the Configuration dialog box which is described later in this chapter.

Executing an Expression

To execute an expression, you type it into the input line, then press Enter (ER). Alternatively, you can select Execute from the Action menu. Following execution, the expression and any displayed results become part of the session log.

Instead of entering a new expression in the input line, you can move back through the session log and re-execute a previous expression (or line of a result) by simply pointing at it with the cursor and pressing Enter. Alternatively, you can select Execute from the Action menu. You may alter the line before executing it. If you do so, it will be displayed using colour 249 (Red on White), the same as that used for the input line. When you press Enter the new line is copied to the input line prior to being executed. The original line is restored and redisplayed in the normal session log colour 250 (Black on White).
An alternative way to retrieve a previously entered expression is to use Ctrl+Shift+Bksp (BK) and Ctrl+Shift+Enter (FD). These commands cycle backwards and forwards through the input history, successively copying previously entered expressions over the current line. When you reach the expression you want, simply press Enter to re-run it. These operations may also be performed from the Edit menu in the session window.

**Executing Several Expressions**

You can execute several expressions, by changing more than one line in the session log before pressing Enter. Each line that you change will be displayed using colour 249 (Red on White). When you press Enter, these marked lines are copied down and executed in the order they appear in the log.

Note that you don't actually have to change a line to mark it for re-execution; you can mark it by overtyping a character with the same character, or by deleting a leading space for instance.

It is also possible to execute a contiguous block of lines. To do this, you must first select the lines (by dragging the mouse or using the keyboard) and then copy them into the clipboard using Shift+Delete (CT) or Ctrl+Insert (CP). You then paste them back into the session using Shift+Insert (PT). Lines pasted into the session are always marked (Red on White) and will therefore be executed when you press Enter. To execute lines from an edit window, you use a similar procedure. First select the lines you want to execute, then cut or copy the selection to the clipboard. Then move to the session window and paste them in, then press Enter to execute them.

**Session Print Width (PW)**

Throughout its history, APL has used a system variable ⎕PW to specify the width of the user's terminal or screen. Session output that is longer than ⎕PW is automatically wrapped and split into multiple lines on the display. This feature of APL was designed in the days of hard-copy terminals and has become less relevant in modern Windows environments.

Dyanal APL continues to support the traditional use of ⎕PW, but also provides an alternative option to have the system wrap Session output according to the width of the Session Window. This behaviour may be selected by checking the Auto PW checkbox in the Session tab of the Configuration dialog box.
Using Find/Replace in the Session

The search and replace facilities work not just in the Editor as you would expect, but also in the Session. For example, if you have just entered a series of expressions involving a variable called SALES and you want to perform the same calculations using NEWSALES, the following commands will achieve it:

Enter SALES in the Find box, and NEWSALES in the Replace box. Now click the Replace All button. You will see all occurrences of SALES change to NEWSALES. Furthermore, each changed line in the session becomes marked (Red on White). Now click on the session and press Enter (or select Execute from the Action menu).

Once displayed, the Find or Find/Replace dialog box remains on the screen until it is either closed or replaced by the other. This is particularly convenient if the same operations are to be performed over and over again, and/or in several windows. Find and Find/Replace operations are effective in the window that previously had the focus.
Value Tips

If you hover the mouse pointer over a name in the Session or Debugger window, APL will display a pop-up window containing the value of the symbol under the mouse pointer.

For example, in the following picture the mouse pointer was moved over the name of the variable \texttt{HW} in the Session window.

![Value Tip example](image)

The next picture illustrates the Value Tip displayed when the mouse is hovered over the name of the variable \texttt{MAT}.

![Value Tip example](image)
Similarly, if you hover the mouse pointer over the name of a function, the system displays the body of the function as a pop-up, as illustrated below.

```
clear ws
HW='Hello World'
MAT=3 4 5
)WARS
HW MAT
)COPY UTIL MATRIX
C:\Program Files\Dyalog\Dyalog APL-6.4 18.0 Unicode\ws\UTIL.dws saved Mon Apr 20 20:32:24 2020
FNS

MAT[2] : R=MATRIX X A Converts scalars and vectors
[1]   R=(2+1 pX)x m ... to 1 row matrices.

Function Dyadic 04/11/...
Value Tips for External Functions

Value Tips can also be used to investigate the syntax of external functions. If you hover over the name of an external function, the Value Tip displays its Function Signature.

For example, in the example below, the mouse is hovered over the external function `dt.AddMonths` and shows that it requires a single integer as its argument.

```plaintext
clear ws
WS tỉ Using 'System'
dt = DateTime.Now
dt.MethodList
Add AddDays AddHours AddMilliseconds AddMinutes AddMonths
nMonth Equals FromBinary FromFileTime FromFileTimeUtc
TypeCode IsDaylightSavingTime IsLeapYear Parse ParseExact
DateTime ToFileTimeUtcToLocalTime ToLongDateString ToLongTimeString
ToUniversalTime TryParse TryParseExact

dt.AddMonths
```

Should the external function provide more than one signature, they are all shown in the Value Tip as illustrated below. Here the function `ToString` has four different overloads.

```plaintext
clear ws
WS tỉ Using 'System'
dt = DateTime.Now
> Cst dt
#. [System.DateTime]
)METHODS
Add AddDays AddHours AddMilliseconds AddMinutes AddMonths
AddSeconds AddTicks AddYears Compare CompareTo DaysInMonth
Equals FromBinary FromFileTime FromFileTimeUtc FromOADate
GetDateTimeFormats GetHashCode GetType GetTypeCode IsDaylightSavingTime
IsLeapYear Parse ParseExact ReferenceEquals SpecifyKind Subtract
ToBinary ToFileTimeToFileTimeUtcToLocalTime ToLongDateString
ToLongTimeString ToOADate ToShortDateString ToShortTimeString
ToString ToUniversalTime TryParse TryParseExact
```

```
System.String ToString()
System.String ToString(System.String)
System.String ToString(System.IFormatProvider)
System.String ToString(System.String, System.IFormatProvider)
```
Configuring Value Tips

You may enable/disable Value Tips and select other options from the General tab of the Configuration dialog box as shown below.

You may experiment by changing the value of the delay before which Value Tips are displayed, until you find a comfortable setting.

Note that the colour scheme used to display the Value Tip for a function need not necessarily be the same colour scheme as you use for the function editor.
Array Editor

The Array Editor\(^1\) allows you to edit arbitrary arrays. It is invoked by either:

- Clicking the \(\text{Array Editor}\) icon in the Session toolbar when the mouse pointer is over the name of a suitable variable.
- Calling the user command \texttt{array.edit}, specifying the name of a suitable variable as its argument.
- Calling it directly via \(\text{⎕NA}\).

The Array Editor draws data using a format that is similar to the output of the DISPLAY function. For example:

\(^1\)Array Editor Version 1 Release 1 © Copyright davidliebtag.com 2012, 2015
Documentation

Full documentation for the Array Editor, including a list of the keystrokes it uses, is available from the Help menu in the Array Editor's window.

Supported Arrays

The Array Editor supports arrays that consist solely of characters and/or numbers. You may not use it to edit an array that contains an object reference or a ⎕OR.

Reject unsupported data

The way that the Arrays Editor reacts to unsupported arrays is determined by the value of the Reject unsupported data option which is accessed by the Options/Reject unsupported data menu item on the Array Editor menubar.

If this is set to true (the default), and you try to edit an array containing an object reference, the Array Editor will refuse to start and the system will generate an error message.

```plaintext
[se.numed]: Unexpected error in array editor: 
DOMAIN ERROR Argument contained data that is 
neither simple or nested.
```

If this option is cleared, the Array editor will start but you will not be able to do anything. It is therefore advisable that you leave this option set.

Notes

- The Array Editor is supplied only with Unicode Editions of Dyalog APL/W. Please visit www.davidliebtag.com for details about availability and support for Classic Editions of Dyalog APL/W.
- Namespaces are not supported.
- Internal representations returned by ⎕OR are not supported.
- Only one instance of the Array Editor may be executed at a time.
- All calls to interpreter primitives use a value of 3 for ⎕ML.
- Negative numbers must be represented using high minus signs. For example, ¯3 not −3.
Implementation

The Array Editor is implemented by a DLL named dlaedit.dll (32-bit) or dlaedit64.dll (64-bit).

The DLL exports two functions: DyalogEditArray and DyalogEditArrayTitle. The latter is used when you click the icon in the Session toolbar (via the APL function ⎕SE.NumEd.numed) and by the user command array.edit

Calling the Array Editor Directly

If you wish to use the Array Editor directly, you may do so as follows using ⎕NA.

For both DyalogEditArray and DyalogEditArrayTitle the first argument is the array to be edited, while the second argument is a place holder and should always be 0

For DyalogEditArrayTitle the 3rd argument is a character vector whose contents are displayed in the caption of the array editor window.

The result is the newly altered array.

Examples

```apl
⎕NA'dlaedit.dll|DyalogEditArray <pp >pp' ⍝ 32-bit
⎕NA'dlaedit.dll|DyalogEditArrayTitle <pp >pp <0C2[]' ⍝ 32-bit
⎕NA'dlaedit64.dll|DyalogEditArray <pp >pp' ⍝ 64-bit
⎕NA'dlaedit64.dll|DyalogEditArrayTitle <pp >pp <0C2[]' ⍝ 64-bit
New←DyalogEditArray Old 0
New←DyalogEditArrayTitle Old 0 Name
```

^Note that these are not standard ⎕NA calls, but rather use an extension to ⎕NA, called Direct Workspace Access. Dyalog does not intend to make this feature generally available at present: if you are interested in this feature please contact sales@dyalog.com.
The Session GUI Hierarchy

As distributed, the Session object ⎕SE contains two CoolBar objects. The first, named ⎕SE.cbtop runs along the top of the Session window and contains the toolbars. The second, named ⎕SE.cbbot, runs along the bottom of the Session windows and contains the statusbars.

The menubar is implemented by a MenuBar object named ⎕SE.mb.

The toolbars in ⎕SE.cbtop are implemented by four CoolBand objects, bandtb1, bandtb2, bandtb3 and bandtb4 each containing a ToolControl named tb.

The statusbars in ⎕SE.cbbot are implemented by two CoolBand objects, bandtb1 and bandtb2, each containing a StatusBar named sb.
The Session MenuBar

The Session MenuBar (⎕SE.mb) contains a set of menus as follows. Note that, unless specified, the screen-shots are taken using Unicode Edition and the keyboard short-cuts will be different in Classic Edition.

The File Menu

The File menu (⎕SE.mb.file) provides a means to execute those APL System Commands that are concerned with the active and saved workspaces. The contents of a typical File menu and the operations they perform are illustrated below.
<table>
<thead>
<tr>
<th>Item</th>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>[WSClear]</td>
<td>Prompts for confirmation, then clears the workspace</td>
</tr>
<tr>
<td>Open</td>
<td>[WSLoad]</td>
<td>Prompts for a workspace file name, then loads it</td>
</tr>
<tr>
<td>Copy</td>
<td>[WSCopy]</td>
<td>Prompts for a workspace file name, then copies it</td>
</tr>
<tr>
<td>Save</td>
<td>[WSSave]</td>
<td>Saves the active workspace</td>
</tr>
<tr>
<td>Save As</td>
<td>[WSSaveas]</td>
<td>Prompts for a workspace file name, then saves it</td>
</tr>
<tr>
<td>Export</td>
<td>[Makeexe]</td>
<td>Creates a bound executable, an OLE Server, an ActiveX Control, or a .NET Assembly. See <em>Installation &amp; Configuration Guide: Creating Executables and OLE Servers</em>.</td>
</tr>
<tr>
<td>Export to Memory</td>
<td>[MakeMemory Assembly]</td>
<td>Creates an in-memory .NET Assembly</td>
</tr>
<tr>
<td>Close AppDomain</td>
<td>[CloseAppDomain]</td>
<td>Closes .NET App Domain</td>
</tr>
<tr>
<td>Drop</td>
<td>[WSDrop]</td>
<td>Prompts for a workspace file name, then erases it</td>
</tr>
<tr>
<td>Edit Text File</td>
<td>[EditTextFile]</td>
<td>Displays the Open Source File dialog to select a file to exit.</td>
</tr>
<tr>
<td>Print</td>
<td>[PrintFnsInNS]</td>
<td>Prints functions and operators in current namespace</td>
</tr>
<tr>
<td>Print Setup</td>
<td>[PrintSetup]</td>
<td>Invokes the print set-up dialog box</td>
</tr>
<tr>
<td>Continue</td>
<td>[Continue]</td>
<td>Saves the active workspace in CONTINUE.DWS and exits APL</td>
</tr>
<tr>
<td>Exit</td>
<td>[Off]</td>
<td>Exits APL</td>
</tr>
</tbody>
</table>
Edit Text File

The Edit Text File menu item allows you to edit a Dyalog script file (.dyalog) or an arbitrary text file. The system prompts you to choose the file as shown below:

The file is then displayed in the Editor, allowing you to change it and save it. See *Editing Scripts and Text Files on page 149*. 
The Edit Menu

The Edit menu (SE.mb.edit) provides a means to recall previously entered input lines for re-execution and for copying text to and from the clipboard.

Unicode Edition

Classic Edition
Table 8: Edit menu operations

<table>
<thead>
<tr>
<th>Item</th>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Back</td>
<td>[Undo]</td>
<td>Displays the previous input line. Repeated use of this command cycles back through the input history.</td>
</tr>
<tr>
<td>Forward</td>
<td>[Redo]</td>
<td>Displays the next input line. Repeated use of this command cycles forward through the input history.</td>
</tr>
<tr>
<td>Cut</td>
<td>[Delete]</td>
<td>Cuts the selected text to the clipboard</td>
</tr>
<tr>
<td>Copy</td>
<td>[Copy]</td>
<td>Copies the selection to the clipboard</td>
</tr>
<tr>
<td>Paste</td>
<td>[Paste]</td>
<td>Pastes the text contents of the clipboard into the session log at the current location. The new lines are marked and may be executed by pressing Enter.</td>
</tr>
<tr>
<td>Paste Unicode</td>
<td>[PasteUnicode]</td>
<td>Same as Paste, but gets the Unicode text from the clipboard and converts to ⎕AV. Classic Edition only</td>
</tr>
<tr>
<td>Paste Non-Unicode</td>
<td>[PasteAscii]</td>
<td>Same as Paste, but gets the ANSI text from the clipboard and converts to ⎕AV. Classic Edition only</td>
</tr>
<tr>
<td>Find</td>
<td>[Find]</td>
<td>Displays the Find dialog box</td>
</tr>
<tr>
<td>Replace</td>
<td>[Replace]</td>
<td>Displays the Find/Replace dialog box</td>
</tr>
</tbody>
</table>
The View Menu

The View menu (⎕SE.mb.view) toggles the visibility of the Session Toolbar, StatusBar, and Language Bar.

![View Menu](image)

Table 9: View menu operations

<table>
<thead>
<tr>
<th>Item</th>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toolbar</td>
<td>Shows/Hides</td>
<td>Session toolbars</td>
</tr>
<tr>
<td>Statusbar</td>
<td>Shows/Hides</td>
<td>Session statusbars</td>
</tr>
<tr>
<td>LanguageBar</td>
<td>Shows/Hides</td>
<td>Language Bar</td>
</tr>
</tbody>
</table>

The Window Menu

This contains a single action (⎕SE.mb.windows) which is to close all of the Edit and Trace windows and the Status window.

![Window Menu](image)

Table 10: Window menu operations

<table>
<thead>
<tr>
<th>Item</th>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close all Windows</td>
<td>[CloseAll]</td>
<td>Closes all Edit and Trace windows</td>
</tr>
</tbody>
</table>

Note that [CloseAll] removes all Trace windows but does not reset the state indicator.

In addition, the Window menu will contain options to switch the focus to any subsidiary windows that are docked in the Session as illustrated above.
The Session Menu

The Session menu (⎕SE.mb.session) provides access to the system operations that allow you to load a session (⎕SE) from a session file and to save your current session (⎕SE) to a session file. If you use these facilities rarely, you may wish to move them to (say) the Options menu or even dispense with them entirely.

Table 11: Session menu operations

<table>
<thead>
<tr>
<th>Item</th>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open</td>
<td>[SELoad]</td>
<td>Prompts for a session file name, then loads the session from it, replacing the current one. Sets the File property of ⎕SE to the name of the file from which the session was loaded.</td>
</tr>
<tr>
<td>Save</td>
<td>[SESave]</td>
<td>Saves the current session (as defined by ⎕SE) to the session file specified by the File property of ⎕SE</td>
</tr>
<tr>
<td>Save As</td>
<td>[SESaveAs]</td>
<td>Prompts for a session file name, then saves the current session (as defined by ⎕SE) in it. Resets the File property of ⎕SE.</td>
</tr>
</tbody>
</table>
The Log Menu

The Log menu (⎕SE.mb.log) provides access to the system operations that manipulate Session log files.

Table 12: Log menu operations

<table>
<thead>
<tr>
<th>Item</th>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clear</td>
<td>[NewLog]</td>
<td>Prompts for confirmation, then empties the current Session log</td>
</tr>
<tr>
<td>Open</td>
<td>[OpenLog]</td>
<td>Prompts for a Session log file, then loads it into memory, replacing the current Session log</td>
</tr>
<tr>
<td>Save</td>
<td>[SaveLog]</td>
<td>Saves the current Session log in the current log file, replacing its previous contents</td>
</tr>
<tr>
<td>Save As</td>
<td>[SaveLogAs]</td>
<td>Prompts for a file name, then saves the current Session log in it</td>
</tr>
<tr>
<td>Print</td>
<td>[PrintLog]</td>
<td>Prints the contents of the Session log</td>
</tr>
</tbody>
</table>

The Action Menu

The Action menu (⎕SE.mb.action) may be used to perform a variety of operations on the current object or the current line. The current object is the object whose name contains the cursor. The current line is that line that contains the cursor. The Edit, Copy Object, Paste Object and Print Object items operate on the current object. For example, if the name SALES appears in the session and the cursor is placed somewhere within it, SALES is the current object and will be copied to the clipboard by selecting Copy object or opened up for editing by selecting Edit.
### Table 13: Action menu operations

<table>
<thead>
<tr>
<th>Item</th>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit</td>
<td>[Edit]</td>
<td>Edit the current object</td>
</tr>
<tr>
<td>Trace</td>
<td>[Trace]</td>
<td>Executes the current line under the control of the Tracer</td>
</tr>
<tr>
<td>Execute</td>
<td>[Execute]</td>
<td>Executes the current line</td>
</tr>
<tr>
<td>Copy Object</td>
<td>[ObjCopy]</td>
<td>Copies the contents of the current object to the clipboard</td>
</tr>
<tr>
<td>Paste Object</td>
<td>[ObjPaste]</td>
<td>Pastes the contents of the clipboard into the current object, replacing its previous value</td>
</tr>
<tr>
<td>Print Object</td>
<td>[ObjPrint]</td>
<td>Prints the current object. Note that if the object is being edited, the version of the object displayed in the edit window is printed.</td>
</tr>
<tr>
<td>Clear Stops</td>
<td>[ClearTSM]</td>
<td>Clears all ⎕STOP, ⎕MONITOR and ⎕TRACE settings</td>
</tr>
<tr>
<td>Interrupt</td>
<td>[Interrupt]</td>
<td>Generates a weak interrupt</td>
</tr>
<tr>
<td>Reset</td>
<td>[Reset]</td>
<td>Performs )RESET</td>
</tr>
</tbody>
</table>
The Options Menu

The *Options* menu (`⎕SE.mb.options`) provides configuration options.

Table 14: Options menu operations

<table>
<thead>
<tr>
<th>Item</th>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expose GUI Properties</td>
<td><code>[ExposeGUI]</code></td>
<td>Exposes the names of properties, methods and events in GUI objects</td>
</tr>
<tr>
<td>Expose Root Properties</td>
<td><code>[ExposeRoot]</code></td>
<td>Exposes the names of the properties, methods and events of the Root object</td>
</tr>
<tr>
<td>Expose Session Properties</td>
<td><code>[ExposeSession]</code></td>
<td>Exposes the names of the properties, methods and events of <code>⎕SE</code></td>
</tr>
<tr>
<td>Line Numbers</td>
<td><code>[LineNumbers]</code></td>
<td>Toggle the display of line numbers in edit and trace windows on/off</td>
</tr>
<tr>
<td>Disable traps in session</td>
<td><code>[DisableTrapsAtSuspension]</code></td>
<td>Disables the error trapping mechanism used by <code>:</code>Trap and <code>⎕TRAP</code>. This can be useful in debugging applications.</td>
</tr>
<tr>
<td>Configure</td>
<td><code>[Configure]</code></td>
<td>Displays the <code>Configuration</code> dialog box</td>
</tr>
<tr>
<td>Colours</td>
<td><code>[ChooseColors]</code></td>
<td>Displays the <code>Colours Selection</code> dialog box</td>
</tr>
</tbody>
</table>
The values associated with the *Expose GUI*, *Expose Root* and *Expose Session* options reflect the values of these settings in your current workspace and are saved in it. When you change these values through the *Options* menu, you are changing them in the current workspace only.

The default values of these items are defined by the parameters *default_wx*, *PropertyExposeRoot* and *PropertyExposeSE* which may be set using the *Object Syntax* tab of the *Configuration* dialog.

**The Tools Menu**

The *Tools* menu ([SE.mb.tools]) provides access to various session tools and dialog boxes.

<table>
<thead>
<tr>
<th>Item</th>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Explorer</td>
<td>[Explorer]</td>
<td>Displays the <em>Workspace Explorer</em> tool</td>
</tr>
<tr>
<td>Search</td>
<td>[WSSearch]</td>
<td>Displays the <em>Workspace Search</em> tool</td>
</tr>
<tr>
<td>Status</td>
<td>[Status]</td>
<td>Displays or hides the <em>Status</em> window</td>
</tr>
<tr>
<td>AutoStatus</td>
<td>[AutoStatus]</td>
<td>Toggle; if checked, causes the <em>Status</em> window to be displayed when a new message is generated for it</td>
</tr>
<tr>
<td>Event Viewer</td>
<td>[EventViewer]</td>
<td>Displays or hides the <em>Event Viewer</em></td>
</tr>
<tr>
<td>Properties</td>
<td>[ObjProps]</td>
<td>Displays a property sheet for the current object</td>
</tr>
</tbody>
</table>
The Threads Menu

The *Threads* menu (\texttt{SE.mb.threads}) provides access to various session tools and dialog boxes.

Table 16: Threads Menu Operations

<table>
<thead>
<tr>
<th>Item</th>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Threads</td>
<td>[Threads]</td>
<td>Displays the <em>Threads Tool</em></td>
</tr>
<tr>
<td>Show Stack</td>
<td>[Stack]</td>
<td>Displays the <em>SI Stack</em> window</td>
</tr>
<tr>
<td>Show Token Pool</td>
<td>[TokenPool]</td>
<td>Displays the <em>Token Pool</em> window</td>
</tr>
<tr>
<td>Auto Refresh</td>
<td>[ThreadsAutoRefresh]</td>
<td>Refreshes the <em>Threads Tool</em> on every thread switch</td>
</tr>
<tr>
<td>Pause on Error</td>
<td>[ThreadsPauseOnError]</td>
<td>Pauses all threads on error</td>
</tr>
<tr>
<td>Pause all Threads</td>
<td>[ThreadsPauseAll]</td>
<td>Pauses all threads</td>
</tr>
<tr>
<td>Resume all Threads</td>
<td>[ThreadsResumeAll]</td>
<td>Resumes all threads</td>
</tr>
<tr>
<td>Restart all Threads</td>
<td>[ThreadsRestartAll]</td>
<td>Restarts all threads</td>
</tr>
</tbody>
</table>
The Help Menu

The Help menu (\SE.mb.help) provides access to the help system which is packaged as a single Microsoft HTML Help compiled help file named help\dyalog.chm.
Table 17: Help menu operations

<table>
<thead>
<tr>
<th>Label</th>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Getting Started</td>
<td>[GettingStarted]</td>
<td>Opens your web browser on the getting-started page on the Dyalog web site</td>
</tr>
<tr>
<td>Dyalog Help</td>
<td>[WelcomeHelp]</td>
<td>Opens help\dyalog.chm, starting at the Welcome page</td>
</tr>
<tr>
<td>Language Elements</td>
<td>[LangHelp]</td>
<td>Opens help\dyalog.chm, starting at the first topic in the Language Reference section</td>
</tr>
<tr>
<td>GUI Overview</td>
<td>[GuiHelp]</td>
<td>Opens help\dyalog.chm, starting at the first topic in the Object Reference section</td>
</tr>
<tr>
<td>Documentation Centre</td>
<td>[DocCenter]</td>
<td>Opens your web browser on help\index.html which displays an index to the on-line PDF documentation and selected internet links</td>
</tr>
<tr>
<td>Dyalog Web Site</td>
<td>[DyalogWeb]</td>
<td>Opens your web browser on the Dyalog home page</td>
</tr>
<tr>
<td>Email Dyalog</td>
<td>[DyalogEmail]</td>
<td>Opens your email client and creates a new message to Dyalog Support</td>
</tr>
<tr>
<td>Latest Enhancements</td>
<td>[RelNotes]</td>
<td>Opens help\dyalog.chm, starting at the first topic in the Version 18.2 Release Notes section. Previous Release Notes are also included for your convenience.</td>
</tr>
<tr>
<td>Read Me</td>
<td>[ReadMe]</td>
<td>Opens help\dyalog\readme.htm in your default web browser. Note that setup\readme.htm is also included in this directory</td>
</tr>
<tr>
<td>Third Party Licences</td>
<td>[LicenceHelp]</td>
<td>Opens help\dyalog.chm, starting at the first topic in the Licences for third-party components</td>
</tr>
<tr>
<td>About</td>
<td>[About]</td>
<td>Displays an About dialog box</td>
</tr>
</tbody>
</table>
Session Pop-Up Menu

The Session popup menu (⎕SE popup) is displayed by clicking the right mouse button anywhere in the Session or Editor window.
If the mouse pointer is over a visible object name, the popup menu allows you to edit, print, delete it or view its properties. Note that the name of the pop-up menu is specified by the Popup property of ⎕SE.

**Table 18: Session popup menu operations**

<table>
<thead>
<tr>
<th>Item</th>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit</td>
<td>[Edit]</td>
<td>Edits the current object</td>
</tr>
<tr>
<td>Chart Wizard</td>
<td>⎕SE.Dyalog.Chart.DoChart</td>
<td>Opens Chart Wizard on current object</td>
</tr>
<tr>
<td>Print</td>
<td>[ObjPrint]</td>
<td>Prints the current object. Note that if the object is being edited, the version of the object displayed in the edit window is printed.</td>
</tr>
<tr>
<td>Delete</td>
<td>[ObjDelete]</td>
<td>Erases the current object</td>
</tr>
<tr>
<td>Properties</td>
<td>[GUIHelp]</td>
<td>Displays the <em>Object Properties</em> dialog box for the current object</td>
</tr>
<tr>
<td>Help</td>
<td>[Help]</td>
<td>Displays the help topic associated with the current object or the APL symbol under the cursor</td>
</tr>
<tr>
<td>Select All</td>
<td>[selectAll]</td>
<td>Selects all text (Editor only)</td>
</tr>
<tr>
<td>Cut</td>
<td>[Cut]</td>
<td>Deletes selected text</td>
</tr>
<tr>
<td>Copy</td>
<td>[Copy]</td>
<td>Copies the selection to the clipboard</td>
</tr>
<tr>
<td>Item</td>
<td>Action</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>----------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Paste</td>
<td>[Paste]</td>
<td>Pastes the text contents of the clipboard into the session log at the current location. The new lines are marked and may be executed by pressing Enter.</td>
</tr>
<tr>
<td>Paste Unicode</td>
<td>[PasteUnicode]</td>
<td>Same as Paste, but gets the Unicode text from the clipboard and converts to ⎕AV</td>
</tr>
<tr>
<td>Paste Non-Unicode</td>
<td>[PasteAnsi]</td>
<td>Same as Paste, but gets the ANSI text from the clipboard and converts to ⎕AV</td>
</tr>
<tr>
<td>Copy Object</td>
<td>[ObjCopy]</td>
<td>Copies the contents of the current object to the clipboard</td>
</tr>
<tr>
<td>Paste Object</td>
<td>[ObjPaste]</td>
<td>Pastes the contents of the clipboard into the current object</td>
</tr>
<tr>
<td>Line Numbers</td>
<td>[LineNumbers]</td>
<td>Toggles line numbers on/off</td>
</tr>
<tr>
<td>Align Comments</td>
<td>[AlignComments]</td>
<td>Aligns Comments to current column</td>
</tr>
<tr>
<td>Explorer</td>
<td>[Explorer]</td>
<td>Displays the Workspace Explorer</td>
</tr>
<tr>
<td>Search</td>
<td>[WSSearch]</td>
<td>Displays the Find Objects tool</td>
</tr>
<tr>
<td>Event Viewer</td>
<td>[EventViewer]</td>
<td>Displays the Event Viewer</td>
</tr>
<tr>
<td>Threads</td>
<td>[Threads]</td>
<td>Displays the Threads Tool</td>
</tr>
<tr>
<td>Status</td>
<td>[Status]</td>
<td>Displays the Status window</td>
</tr>
<tr>
<td>Item</td>
<td>Action</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Colours</td>
<td>[ChooseColors]</td>
<td>Displays the <em>Colour Selection</em> dialog</td>
</tr>
<tr>
<td>Interrupt</td>
<td>[Interrupt]</td>
<td>Generates a weak interrupt</td>
</tr>
<tr>
<td>Open link</td>
<td>[OpenLink]</td>
<td>Opens the URL or link using the appropriate program. Unicode Edition only.</td>
</tr>
<tr>
<td>Copy link to clipboard</td>
<td>[CopyLink]</td>
<td>Copies the URL or link to the Windows Clipboard. Unicode Edition only.</td>
</tr>
</tbody>
</table>

For the last two items, see *Installation & Configuration Guide: Configuration Dialog: General Tab*)
The Session Toolbars

The Session toolbars are contained by four separate CoolBand objects, allowing you to configure their order in whichever way you choose. The tool buttons appear differently according to whether or not Native Look and Feel is enabled.

The bitmaps for the buttons displayed on the session tool bar are implemented by three ImageList objects owned by the CoolBar \SE.cbttop. These represent the ToolButton images in their normal, highlighted and inactive states and are named iln, ilh and ili respectively. These images derive from three bitmap resources contained in dyalog.exe named tb_normal, tb_hot and tb_inactive.

If Native Look and Feel is enabled all three bitmap resources are mapped to a different set of images which are capable of reflecting the Visual Styles in use.

Native Look and Feel Enabled

Native Look and Feel Disabled
Workspace (WS) Operations

- **Clear Workspace**
  - Executes the system operation [WSClear] which asks for confirmation, then clears the workspace

- **Load Workspace**
  - Executes the system operation [WSLoad] which displays a file selection dialog box and loads the selected workspace

- **Copy Workspace**
  - Executes the system operation [WSCopy] which displays a file selection dialog box and copies the (entire) selected workspace

- **Save Workspace**
  - Executes the system operation [WSSaveas] which displays a file selection dialog box and saves the workspace in the selected file

- **Export Workspace**
  - Executes the system operation [MakeExe] which re-exports the workspace using the settings, parameters and options that were previously selected using the Create Bound File dialog

- **Print Functions**
  - Executes the system operation [PrintFnsInNS] that prints all the functions and operators in the current namespace
Object Operations

- **Copy Object**: Executes the system operation `[ObjCopy]` which copies the contents of the current object to the clipboard.

- **Paste Object**: Executes the system operation `[ObjPaste]` which copies the contents of the clipboard into the current object, replacing its previous value.

- **Print Object**: Executes the system operation `[ObjPrint]`. Prints the current object. Note that if the object is being edited, the version of the object displayed in the edit window is printed.

- **Edit Object**: Executes the system operation `[Edit]` which edits the current object using the standard system editor.

- **Edit Array**: Executes a defined function in ⎕SE that edits the current object using the Array Editor (Unicode Edition) or a spreadsheet-like interface based upon the Grid object (Classic Edition). See Array Editor on page 37.

- **SharpPlot**: Executes a defined function in ⎕SE that runs the Chart Wizard to plot the current object using the jchart User Command.
Tools

- Explorer: Executes the system operation [Explorer] which displays the *Workspace Explorer* tool.
- Search: Executes the system operation [WSSearch] which displays the *Workspace Search* tool.
- Line Numbers: Executes the system operation [LineNumbers] which toggles the display of line numbers in edit and trace windows on and off.
- Clear all Stops: Executes the system operation [ClearTSM] which clears all ⎕STOP, ⎕MONITOR and ⎕TRACE settings.

Edit Operations

- Copy Selection: Executes the system operation [Copy] which copies the selected text to the clipboard.
- Paste Selection: Executes the system operation [Paste] which pastes the text in the clipboard into the current window at the insertion point.
- Recall Last: Executes the system operation [Undo] which recalls the previous input line from the input history stack.
- Recall Next: Executes the system operation [Redo] which recalls the next input line from the input history stack.
Session Operations

Load Session

Executes the system operation \texttt{[SELoad]} which displays a file selection dialog box and loads the selected Session File.

Boxing On/Off

Executes the user command \texttt{boxing} to toggle boxing on/off.

Select Font

Selects the font to be used in the Session window.

Select Font Size

Selects the size of the font to be used in the Session window.
The Session Status Bar

The session status bar is represented by two CoolBands each of which contains aStatusBar object. There are a number of StatusFields as illustrated below. Your own status bar may be configured differently.

![Session Status Bar](image)

**Classic Edition**

![Classic Edition](image)

**Unicode Edition**

The StatusField objects owned by the session StatusBar may have special values of Style, which are used for operations relevant only to the Session. These styles are summarised in the tables shown below.

**Table 19: Session status fields: first row**

<table>
<thead>
<tr>
<th>StatusField</th>
<th>Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>hint</td>
<td>None</td>
<td>Displays hints for the session objects, or &quot;Ready...&quot; when APL is waiting for input</td>
</tr>
<tr>
<td>insrep</td>
<td>InsRep</td>
<td>Displays the mode of the Insert key (Ins or Rep)</td>
</tr>
<tr>
<td>mode</td>
<td>KeyMode</td>
<td>Displays the keyboard mode. This is applicable only to a multi-mode keyboard. The text displayed is defined by the Mn= string in the Input Table. <strong>Classic Edition Only</strong></td>
</tr>
<tr>
<td>num</td>
<td>NumLock</td>
<td>Indicates the state of the Num Lock key. Displays &quot;NUM&quot; if Num Lock is on, blank if off</td>
</tr>
<tr>
<td>caps</td>
<td>CapsLock</td>
<td>Indicates the state of the Caps Lock key. Displays &quot;Caps&quot; if Caps Lock is on, blank if off</td>
</tr>
<tr>
<td>pause</td>
<td>Pause</td>
<td>Displays a flashing red &quot;Pause&quot; message when the Pause key is used to halt session output</td>
</tr>
</tbody>
</table>
Table 20: Session status fields: second row

<table>
<thead>
<tr>
<th>StatusField</th>
<th>Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>curobj</td>
<td>CurObj</td>
<td>Displays the name of the current object (the name last under the input cursor)</td>
</tr>
<tr>
<td>tc</td>
<td>ThreadCount</td>
<td>Displays the number of threads currently running (minimum is 1)</td>
</tr>
<tr>
<td>dqlen</td>
<td>DQLen</td>
<td>Displays the number of events in the APL event queue</td>
</tr>
<tr>
<td>trap</td>
<td>Trap</td>
<td>Turns red if ⎕TRAP is set</td>
</tr>
<tr>
<td>si</td>
<td>SI</td>
<td>Displays the length of ⎕SI. Turns red if non-zero</td>
</tr>
<tr>
<td>io</td>
<td>IO</td>
<td>Displays the value of ⎕IO. Turns red if ⎕IO is not equal to the value of the default_io parameter</td>
</tr>
<tr>
<td>ml</td>
<td>ML</td>
<td>Displays the value of ⎕ML. Turns red if ⎕ML is not equal to the value of the default_ml parameter</td>
</tr>
</tbody>
</table>

Toggle Status Fields

In the default Session files distributed with this release, the Statusfields used to display the value of ⎕IO, the state of the Insert key (Ins/Rep) and the current keyboard mode (e.g. Apl/Uni) have callback functions attached to MouseDbIClick. This means that you can toggle the state of these fields by double-clicking with the left mouse button.

If you dislike this behaviour, you may set the Event property of the StatusFields to 0 and re-save the Session file. Alternatively, you may modify the buildse workspace and rebuild the Session from scratch.
Status Window

The Status window is used to display system messages and supplementary information. These include the operations that take place when you register an OLEServer or ActiveXControl.

The Status window is also used to display supplementary information about errors. For example if you attempt to use a .NET method with incorrect argument(s) you will get a suitable error message in the Status window, in addition to the DOMAIN ERROR message in the Session.

Example

```apl
⎕USING←'System'
bd←⎕NEW DateTime(2015 4) A Typo (2015 4 30)
```

The Status window can be explicitly displayed or hidden using the [Status] system operation which is associated with the Tools/Status menu item. There is also an option to have the Status window appear automatically whenever a new message is written to it. This option is selected using the [AutoStatus] system operation which is associated with the Tools/AutoStatus menu item.

Note that when you close the Status window, all the system messages in it are cleared.
The Workspace Explorer Tool

The Explorer tool is a modeless dialog box that may be toggled on and off by the system action [Explorer]. In a default Session, this is attached to a MenuItem in the Tools menu and a Button on the session toolbar.

The Explorer contains two sub-windows. The one on the left displays the namespace structure of your workspace using a TreeView. The right-hand window is a ListView that displays the contents of the namespace that is selected in the TreeView.

The Explorer is closely modelled on the Windows Explorer in Windows and the facilities it provides are very similar. For Windows users, the operation of this tool is probably self-explanatory. However, other users may find the following discussion useful.
Exploring the Workspace

The TreeView displays the structure of your workspace. Initially it shows the root and Session namespaces # and ⎕SE. The icon for # is open indicating that its contents are those that appear in the ListView. You can expand or collapse the TreeView of the workspace structure by clicking on the mini-buttons (labelled + and -) or by double-clicking the icons. A single click on a namespace icon opens it and causes its contents to be displayed in the ListView. Another way to open a namespace is to double-click its icon in the ListView. Only one namespace can be open at a time. The icons used in the display are described below.

- Class
- Namespace
- GUI Namespace
- Function
- Variable
- Operator
- Indicates an object that has been erased
- Type Library
- .NET object
Viewing and Arranging Objects

The ListView displays the contents of a namespace in one of four different ways namely Large Icons view, Small Icons view, List Icons view or Details view. You can switch between views using the View menu or the tool buttons that are provided. In the first three views, the system displays the name of the object together with an icon that identifies its type. In Details view, the system displays several columns of additional information. You may resize the column widths by dragging or double-clicking the lines in the header. To hide a column, drag its width to the far left. The additional columns are:

| Location | This is the namespace containing the object. By definition, this is the same for all of the objects shown in the ListView and is normally hidden. |
| Type | Type of object. |
| Description | For a function or operator, this is the function header stripped of localised names and comment. For a variable, the description indicates its rank, shape and data type. For a namespace, the description indicates the nature of the namespace; a plain namespace is described as namespace, a GUI Form object is described as Form, and so forth. |
| Size | The size of the object as reported by \( \text{SIZE} \). |
| Modified on | For functions and operators, this is the timestamp when the object was last fixed. For other objects this field is empty. |
| Modified by | For functions and operators, this is the name of the user who last fixed the object. For other objects this field is empty. |

In any view, you may arrange the objects in ascending order of name, size, timestamp or class by clicking the appropriate tool button. In Details view, you may sort in ascending or descending order by clicking on the appropriate column heading. The first click sorts in ascending order; the second in descending order.
Moving and Copying Objects

You can move and copy objects from one namespace to another using drag-drop or from the Edit menu.

To move one or more objects using drag-and-drop editing:

1. Select the objects you want to move in the ListView.
2. Point to one of the selected objects and then press and hold down the left mouse button. When the drag-and-drop pointer appears, drag the object(s) to another namespace in the TreeView. To indicate which of the namespaces is the current target, its name will be highlighted as you drag the selected object(s) over the TreeView.
3. Release the mouse button to drop the objects into place. The objects will disappear from the ListView because they have been moved to another namespace.

To copy one or more objects using drag-and-drop editing, the procedure is the same except that you must press and hold the Ctrl key before you release the mouse button.

You may also move and copy objects using the Edit menu. To do so, select the object(s) and then choose Move or Copy from the Edit menu. You will be prompted for the name of the namespace into which the objects are to be moved or copied. Enter the namespace and click OK.

Editing and Renaming Objects

You can open up an edit window for a function or variable by double-clicking its icon, or by selecting it and choosing Edit from the Edit menu or from the popup menu. You may rename an object by clicking its name (as opposed to its icon) and then editing this text. You may also select the object and choose Rename from the Edit menu or from the popup menu. Note that when you rename an object, the original name is discarded. Unlike changing a function name in the editor, this is not a copy operation.
Using the Explorer as an Editor

If you open the $Fns/Ops$ item, the names of the functions and operators in the namespace are displayed below it alphabetically in the left (tree view) pane. When you select one of these names, the function itself is opened in the right (list view) pane.

You may use this feature to quickly cycle through the functions (or variables) in a namespace, pressing cursor up and cursor down in the left (tree view) pane to move from one to another.

You may also edit the function directly in the right (list view) pane before moving on to another.
The File Menu

The File menu, illustrated above, provides the following actions. All but Print setup and Close act on the object or objects that are currently selected in the ListView.

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print</td>
<td>Prints the object(s). Note that if an object is open in the editor, the version shown in the edit window is printed.</td>
</tr>
<tr>
<td>Print setup</td>
<td>Displays the Print Configuration dialog box.</td>
</tr>
<tr>
<td>Delete</td>
<td>Erases the object(s).</td>
</tr>
<tr>
<td>Rename</td>
<td>Renames the object. This option only applies when a single object is selected.</td>
</tr>
<tr>
<td>Properties</td>
<td>Displays a property sheet; one for each object that is selected.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the Explorer</td>
</tr>
</tbody>
</table>
The Edit Menu

The Edit menu, illustrated above, provides the following actions. The Edit, Copy and Move operations act on the object or objects that are currently selected in the ListView.

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit</td>
<td>Opens an edit window for each of the objects selected.</td>
</tr>
<tr>
<td>Copy</td>
<td>Prompts for a namespace and copies the object(s) there.</td>
</tr>
<tr>
<td>Move</td>
<td>Prompts for a namespace and moves the object(s) there.</td>
</tr>
<tr>
<td>Select Functions</td>
<td>Selects all of the functions and operators in the ListView.</td>
</tr>
<tr>
<td>Select Variables</td>
<td>Selects all of the variables in the ListView.</td>
</tr>
<tr>
<td>Select None</td>
<td>Deselects all of the objects in the ListView.</td>
</tr>
<tr>
<td>Select All</td>
<td>Selects all of the objects in the ListView.</td>
</tr>
<tr>
<td>Invert Selection</td>
<td>Deselects the selected objects and selects all those that were not selected.</td>
</tr>
</tbody>
</table>
The Options Menu

The Options menu, illustrated above, provides the following actions.

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toolbar</td>
<td>Displays or hides the Explorer toolbar.</td>
</tr>
<tr>
<td>Toolbar Captions</td>
<td>Displays or hides the button captions on the Explorer toolbar.</td>
</tr>
<tr>
<td>Status Bar</td>
<td>Displays or hides the Explorer statusbar.</td>
</tr>
<tr>
<td>Type Libraries</td>
<td>Enables/disables the exploring of Type Libraries</td>
</tr>
<tr>
<td>Expand All</td>
<td>Expands all namespaces and sub-namespaces in the TreeView, providing a complete view of the workspace structure, including or excluding the Session object ⎕SE.</td>
</tr>
<tr>
<td>Refresh Now</td>
<td>Redisplays the TreeView and ListView with the current structure and contents of the workspace. Used if Auto Refresh is not enabled.</td>
</tr>
<tr>
<td>Auto Refresh</td>
<td>Specifies whether or not the Explorer immediately reflects changes in the active workspace.</td>
</tr>
</tbody>
</table>

If Auto Refresh is checked the Explorer is updated every time APL returns to desk-calculator mode. This means that it is always in step with the active workspace. If you have a large number of objects displayed in the Explorer, the update may take a few seconds and you may wish to prevent this by un-checking this menu item. If you do so, the Explorer must be explicitly updated by selecting the Refresh Now action.
The View Menu

The View menu, illustrated above, provides the following actions.

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Columns</td>
<td>Allows you to select which columns you wish to display.</td>
</tr>
<tr>
<td>Large Icons</td>
<td>Selects <em>Large Icons</em> view in the ListView.</td>
</tr>
<tr>
<td>Small Icons</td>
<td>Selects <em>Small Icons</em> view in the ListView.</td>
</tr>
<tr>
<td>List Icons</td>
<td>Selects <em>List Icons</em> view in the ListView.</td>
</tr>
<tr>
<td>Details</td>
<td>Selects <em>Details</em> view in the ListView.</td>
</tr>
<tr>
<td>Scope</td>
<td>Allows you to choose whether the Explorer displays objects in local scope or in global scope.</td>
</tr>
<tr>
<td>Arrange Icons</td>
<td>Sorts the items in the ListView by name, type, size or date.</td>
</tr>
<tr>
<td>Line up Icons</td>
<td>Rearranges the icons into a regular grid.</td>
</tr>
<tr>
<td>Auto Arrange</td>
<td>If checked, the icons are automatically re-arranged when appropriate</td>
</tr>
</tbody>
</table>
## The Tools Menu

The Tools menu, illustrated above, provides the following actions.

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find</td>
<td>Displays the Find Objects Tool</td>
</tr>
<tr>
<td>Go to</td>
<td>Prompts for a namespace and then opens that namespace in the TreeView, displaying its contents in the ListView</td>
</tr>
<tr>
<td>Go to Session Space</td>
<td>Opens the namespace in the TreeView control corresponding to the current space in the Session.</td>
</tr>
<tr>
<td>Set Session Space</td>
<td>Sets the current space in the Session to be the namespace that is currently open in the TreeView.</td>
</tr>
</tbody>
</table>
Browsing Classes

Classes are represented by icons. The picture below shows 3 classes: Bird, Parrot and DomesticParrot.

![Image showing classes in a workspace]

3 object(s). 254.5Mb free. 89008 bytes used (45664 bytes selected...
If you open the \# node in the left-hand pane, you see the contents of \# as a tree.
Browsing Class Scripts

Selecting *DomesticParrot* in the left-hand pane brings up its Class Script in the right-hand pane.
... and selecting *Parrot* in the left-hand pane brings up the Class Script for *Parrot*.
... and finally, selecting \texttt{Bird} in the left-hand pane brings up the Class Script for \texttt{Bird}.
If you open a Class node, a tree appears to help you to navigate within the Class script. In the picture below, the user has opened the [Methods] node and then clicked on **Speak**. The system has responded by scrolling to (if necessary) and highlighting the appropriate section of the script.
Browsing Type Libraries

When the View/Type Libraries option is enabled, the Workspace Explorer allows you to:

- Browse the Type Libraries for all the COM server objects that are installed on your computer, whether or not they are loaded in your workspace.
- Load Type Libraries for COM objects
- Browse the Type Library associated with an OLEClient object that is already instantiated in the workspace.

If the Microsoft .NET Framework is installed, you may in addition:

- Load Metadata for specific .NET classes
- Browse the loaded Metadata, viewing information about classes, methods, properties and so forth.

If the Type Libraries option is enabled, the Workspace Explorer displays a folder labelled TypeLibs which, when opened, displays two others labelled Loaded Libraries and Registered Libraries as shown below.
Browsing Registered Libraries

If you open the Registered Libraries folder, the *Workspace Explorer* will display in the tree view pane the names of all the Type Libraries associated with the COM Server objects that are installed on your computer.

If you select one of these Library names, some summary information is displayed in the list view pane.

For example, the result of selecting the Microsoft Excel 16.0 Object Library is illustrated below.

If instead, you select the Registered Libraries folder itself, the list of Registered Type Libraries is displayed in the list view pane.
Loading a Type Library

You can load a library shown in the tree view pane by selecting *Load* from its context menu.

In either case, a message box will appear asking you to confirm. The operation to load a Type Library may take a few moments to complete.

Notice that if the selected Library references any other libraries, they too will be loaded. For example, loading the *Microsoft Excel 16.0 Object Library* brings in the *Microsoft Office 16.0 Object Library* and the *Microsoft Visual Basic for Applications Extensibility 5.3 Library* too. It also contains references to a general library called the *OLE Automation Type Library*, so this is also loaded.

When you `SAVE` your workspace, all of the Type Libraries that you have loaded will be saved with it. Note that type library information can take up a considerable amount of workspace.
Browsing Loaded Libraries

If you have already loaded any Type Libraries into the workspace, using the Workspace Explorer or as a result of creating one or more OLEClient objects, you can select and open the Loaded Libraries folder.

The picture below illustrates the effect of having loaded the Microsoft Excel 16.0 Object Library.

Notice that any external references to other libraries causes these to be brought in too.

If you select a loaded Type Library, summary information is displayed in the list view pane.

If you open a loaded Type Library, four sub-folders appear named Object CoClasses, Objects, Enums and Event Sets respectively.
Object CoClasses

A Type Library describes a number of objects. Typically, all of the objects have properties and methods, but only some of them, perhaps just a few, generate events. Objects which generate events are represented by CoClasses, each of which has a pointer to the object itself and a pointer to an event set.

For example, the Microsoft Excel 16.0 Object Library contains seven CoClasses named Application, Chart, Global etc as shown below.
Opening the Application folder you can see that the Application CoClass comprises the _Application object coupled with the AppEvents event set as shown below.

The specific methods, properties and events supported by the CoClass object can be examined by opening the appropriate sub-folder. The same information for these and other objects is also accessible from the Objects and Event Sets folders as discussed below.
Objects

The *Objects* folder contains several sub-folders each of which represents a named object defined in the library.

Each object folder contains two sub-folders named Methods and Properties. Selecting one of these causes the list of Methods or Properties to be displayed in the list view pane. The picture below shows the Methods exposed by the Microsoft Excel 16.0 Range object.
If you open the *Methods* or *Properties* subfolder, you can display more detailed information about individual Methods and Properties. For example, the following picture shows information about the *SaveAs* method exposed by the Microsoft Excel 16.0 Worksheet object.

![Screenshot of the APL Environment showing the SaveAs method details](image)

This tells you that the *SaveAs* method takes up to 10 parameters of which the first, Filename, is mandatory and is of data type VT_BSTR (a character string). Note that [in] indicates that the parameter is an *input* parameter.
Incidentally, the optional Fileformat parameter is an example of a parameter whose value must be one of a list of Enumerated Constants. Even without looking at the documentation, the possible values can be deduced by browsing the Enums folder, with the results shown below.

You can therefore deduce that the following expression, executed in the namespace associated with the currently active worksheet, will save the sheet in comma-separated format (CSV) in a file called mysheet.csv:

```
SaveAs 'MYSHEET.CSV' xlCSV
```

or

```
SaveAs 'MYSHEET.CSV' 6
```
Event Sets

The *Event Sets* folder contains several sub-folders each of which represents a named set of events generated by the objects defined in the library.

If you open one of these event sets, the names of the events it contains are displayed in the tree view pane. If you then select one of the events, its details are displayed in the list view pane as shown below.

This example shows that when it fires, the SheetActivate event invokes your callback function with a single argument named *Sh* whose datatype is VT_DISPATCH (in practice, a Worksheet object).
 Enums

The *Enums* folder will typically contain several sub-folders each of which represents a named set of enumerated constants.

If you select one of these sets, the names and values of the constants it contains are displayed in the list view pane as shown below.
Browsing .NET Classes

Microsoft supplies a tool for browsing .NET Class libraries called `ILDASM.EXE`\(^1\).

As a convenience, the Dyalog APL Workspace Explorer has been extended to perform a similar task as `ILDASM` so that you can gain access to the information within the context of the APL environment.

The information that describes .NET classes, which is known as its *Metadata*, is part of the definition of the class and is stored with it. This Metadata corresponds to Type Information in COM, which is typically stored in a separate Type Library.

To gain information about one or more .NET Classes, open the Workspace Explorer, right click the *Metadata* folder, and choose *Load*.

---

\(^1\) `ILDASM.EXE` can be found in the .NET SDK and is distributed with Visual Studio
This brings up the *Browse .NET Assembly* dialog box as shown below. Navigate to the .NET assembly of your choice, and click *Open*.

The .NET Classes provided with the .NET Framework are typically located in C:\WINDOWS\Microsoft.NET\Framework64\V4.0.30319 (on a 64-bit computer). The last named folder is the Version number.

The most commonly used classes of the .NET Namespace System are stored in this directory in an Assembly named mscorlib.dll, along with a number of other fundamental .NET Namespaces.
The result of opening this Assembly is illustrated in the following screen shot. The somewhat complex tree structure that is shown in the Workspace Explorer merely reflects the structure of the Metadata itself.
Opening the *System/ Classes* sub-folder causes the Explorer to display the list of classes contained in the .NET Namespace *System* as shown in the picture below.
The *Constructors* folder shows you the list of all of the valid constructors and their parameter sets with which you may create a new instance of the Class by calling `New`. The constructors are those named `.ctor`; you may ignore the one named `.cctor`, (the class constructor) and any labelled as `Private`.

For example, you can deduce that `DateTime.New` may be called with three numeric (Int32) parameters, or six numeric (Int32) parameters, and so forth. There are in fact seven different ways that you can create an instance of a `DateTime`.

For example, the following statement may be used to create a new instance of `DateTime` (09:30 in the morning on 30th April 2001):

```
mydt←⎕NEW DateTime (2001 4 30 9 30 0)
```

```
mydt
30/04/2001 09:30:00
```
The *Properties* folder provides a list of the properties supported by the Class. It shows the name of the property followed by its data type. For example, the `DayOfYear` property is defined to be of type `Int32`. 
You can query a property by direct reference:

```
my dt.DayOfWeek
Monday
```

Notice too that the data types of some properties are not simple data types, but Classes in their own right. For example, the data type of the `Now` property is itself `System.DateTime`. This means that when you reference the `Now` property, you get back an object that represents an instance of the `System.DateTime` object:

```
my dt.Now
07/11/2001 11:30:48
TS
2001 11 7 11 30 48 0
```
The *Methods* folder lists the methods supported by the Class. The Explorer shows the data type of the result of the method, followed by the name of the method and the types of its arguments. For example, the `IsLeapYear` method takes an `Int32` parameter (year) and returns a `Boolean` result.

```
mydt.IsLeapYear 2000
```

![Workspace Tree](CLEAR_WS_Exploring.png)
Many of the reported objects are listed as *Private*, which means they are inaccessible to users of the class – you are not able to call them or inspect their value. For more information about classes, see *Language Reference Guide: Object Oriented Programming*. 
Find Objects Tool

The *Find Objects* tool is a modeless dialog box that may be toggled on and off by the system action [WSSearch]. In a default Session, this action is attached to a Menu Item in the Tools menu and a Button on the session toolbar.

The Find Objects tool allows you to search the active workspace for objects that satisfy various criteria.

![Find Objects Tool](image)

**Name**

The *Named* field is used to search for objects with a particular name and is case-insensitive.

**Containing Text**

The *Containing Text* field is used to search for objects that contain a particular text string. The string search is controlled by the fields *Match Case*, *Use Regular Expressions*, *Match Whole Word* and *As Symbol Reference*.

*Match Case* specifies whether or not the string search (for name and/or contents) is case sensitive.

*Use Regular Expressions* specifies whether or not regular expressions are applicable. For example, if you enter FOO* into the field labelled *Containing Text* and check this box, the system will find objects that contain any text string starting with the 3 characters FOO.
If this box is not checked, the system will find objects that contain the 4 characters FOO*.

Text searches are performed using PCRE. If the Use Regular Expressions box is checked, the full range of regular expressions provided by PCRE are available for use. See Language Reference Guide: Appendix A.

Match Whole Word specifies whether or not the search is restricted to entire words.

As Symbol Reference specifies whether or not the search is restricted to APL symbols. If so, matching text in comments and other strings is ignored.

**Object Criteria**

Four check boxes are provided for you to specify the types of objects you wish to locate. For example, if you clear Variables, Operators and Namespaces, the system will only search for functions.

To make the search dependent upon modification, you must check the Modified Objects check box.

To locate objects modified by a particular user, enter the user name in the field labelled Modified by. Otherwise leave this blank.

To find objects which have been modified at a certain time or within a specified period of time, check the appropriate radio button and enter the appropriate dates or time spans.

If you wish to restrict the search to find only objects whose size is within a given range, check the box labelled Size is between and enter values into the fields provided.

**Location Criteria**

You can restrict the search to a particular namespace by typing its name into the field labelled Look in. You can further restrict the search by clearing the Include sub-namespaces and Include Session namespace check boxes. Clearing the former restricts the search to the root namespace or to the namespace that you have specified in Look in, and does not search within any sub-namespaces contained therein. Clearing the latter causes the system to ignore ⎕SE in its search.
When you press the *Find Now* button, the system searches for objects that satisfy all of the criteria that you have specified on all 3 pages of the dialog box and displays them in a ListView. The example below illustrates the result of searching the workspace for all objects containing references to the symbol *Speak*.

You may change the way in which the objects are displayed in the ListView using the *View* menu or the tool buttons, in the same manner as for objects displayed in the Workspace Explorer. You may also edit, delete and rename objects in the same way. Furthermore, objects can be copied or moved by dragging from the ListView in the Search tool to the TreeView in the Explorer.

If you wish to specify a completely new set of criteria, press the *New Search* button. This will reset all of the various controls of the dialog box to their default values.
Object Properties Dialog Box

The Object Properties dialog box displays detailed information for an APL object. It is displayed by executing the system action [ObjProps]. In a default Session, this is provided in the Tools menu, the Session popup menu and from the Explorer. An example (for a function) is shown below.

Properties Tab

The Properties tab displays general information about the object. For a function, this includes an extract from its header line, when it was last modified, and by whom.
Value Tab

For a variable, the *Values* tab displays the value of the variable. For a function, it displays its canonical representation.
Monitor Tab

The Monitor tab applies only to a function and displays the result of ⎕MONITOR. The Reset button resets ⎕MONITOR for the lines on which it is currently set. The Set All Lines button sets ⎕MONITOR to monitor all the lines in the function. The Clear All Lines switches ⎕MONITOR off.

![Monitor Tab Image]
COM Properties Tab

The *COM Properties* tab applies only to a function in an OLEServer or ActiveXControl namespace. The tab is used to define arguments and data types for an exported Method or Property. For further information, see *Interface Guide.*
Net Properties Tab

The Net Properties tab applies only to a function in a NetType namespace. The tab is used to define arguments and data types for an exported Method or Property. For further information, see .NET Interface Guide.
The Editor

Invoking the Editor

The editor may be invoked in several ways. From the session, you can use the system command \texttt{ED} or the system function \texttt{⎕ED}, specifying the names(s) of the object(s) to be edited. You can also type the name of the object and then press Shift+Enter (ED), click the \textit{Edit} tool on the tool bar, or select \textit{Edit} from the \textit{Action} menu. If you invoke the editor when the cursor is positioned on the empty input line, with a suspended function in the state indicator, the editor is invoked on the suspended function and the cursor is positioned on the line at which it is suspended. This is termed \textit{naked edit}. These ways of invoking the editor apply only in the session window.

In addition, there is a general \textit{point-and-edit} facility which works in edit and trace windows too. Simply position the input cursor over a name and double-click the left mouse button. Alternatively, you can press Shift+Enter or select \textit{Edit} from the \textit{File} menu. The name can appear in the Session, in an Edit window, or in a Trace window; the effect is the same. Note that, in the Session, typing a name and pressing Shift+Enter is actually a special case of \textit{point-and-edit}. Note also that a \textit{naked edit} can be invoked by double-clicking the left mouse button in the empty input line.
The type of a new object defaults to function/operator unless the object is shadowed, in which case it defaults to a variable (vector of character vectors). You can however specify the type of a new object explicitly using )ED or ⎕ED. For example, typing 
"ED ∊LIST -MAT" in a CLEAR WS would create Edit windows for a vector of character vectors named LIST and a character matrix called MAT. See )ED or ⎕ED for details.

If the name is not already being edited, it is assigned a new edit window. If you edit a name which is already being edited, the system focuses on the existing edit window rather than opening a new one. Edit windows are displayed using the colour combination associated with the type of the object being edited.
Window Management (Standard)

Unless *Classic Dyalog mode* is selected (Options/Configure/Trace/Edit), the Editor is a Multiple Document Interface (MDI) window that may be a stand-alone window, or be docked in the Session window. Each of the objects being edited is displayed in a separate sub-window. Individual edit windows are managed using standard MDI facilities.

The first edit sub-window window is created at the position specified by the `edit_first_y` and `edit_first_x` parameters which are specified in terms of the size of a character in the current font relative to the top-left corner of the main Editor window. Subsequent ones are staggered according to the values of the `edit_offset_y` and `edit_offset_x` parameters.

The initial size of an edit window is specified by the `edit_rows` and `edit_cols` parameters.

Note that the blue triangles indicate that the line of text is longer than can be displayed in the current Edit window.
By default, the Session has the Editor docked along the right edge of the Session window. When you edit a function, the Editor window automatically springs into view as illustrated below.
Chapter 1: The APL Environment

You can resize the Editor pane to view more or less of the Session itself, by dragging its title bar.

Using the buttons in the title bar, you can instantly maximise the Editor pane to allow you to concentrate on editing, or minimise it to reveal the entire Session. In either case, the restore button quickly restores the 2-pane layout.

The picture below shows the effect of maximising the Editor. The `BUILD_SESSION` edit window is itself maximised within the Editor too.

![Maximised Editor and BUILD_SESSION window](image)

Note that when the Editor has the focus, the Editor menubar is displayed in place of the Session menubar.
Window Management (Classic Dyalog mode)

If *Classic Dyalog mode* is selected (Options/Configure/Trace/Edit) each Edit window is a top-level window created as a child of the Session window. This means that normally Edit windows appear on top of the Session. However, if the **SessionOnTop** parameter is set, the Session window, when given the focus, will appear on top of Edit windows.

When the first Edit window is opened, its position is determined as follows:

- If the **ClassicModeSavePosition** parameter is set, the first Edit window is displayed at the position that was previously occupied by the most recently saved Edit window.
- If not, the first edit window is created at the position specified by the **edit_first_y** and **edit_first_x** parameters which are specified in terms of the size of a character in the current font relative to the top-left corner of the screen.

The initial size of an edit window is specified by the **edit_rows** and **edit_cols** parameters.

Subsequent ones are staggered according to the values of the **edit_offset_y** and **edit_offset_x** parameters.
Moving around an edit window

You can move around in the edit window using the scrollbar, the cursor keys, and the PgUp and PgDn keys. In addition, Ctrl+Home (UL) moves the cursor to the beginning of the top-line in the object and Ctrl+End moves the cursor to the end of the last line in the object. Home (LL) and End (RL) move the cursor to the beginning and end respectively of the line containing the cursor.

Closing an edit window

Closing an edit window from its System Menu has the same effect as choosing Exit from the File Menu; namely that it fixes the object in the workspace and then closes the edit window.

Minimising an edit window

Minimising an edit window causes it to be displayed as a Dyalog APL Edit icon, with the name of the object underneath. The edit window can be restored in the normal way, or by an attempt to re-edit the same name.

Selecting Text

You may select text in an Editor window by clicking the left or right mouse button over any character, dragging out a highlighted area, and then releasing the mouse button. When using the left button, moving up or down one line extends the selection from the beginning of that line, so the selection may be ragged. The right button selects a rectangular box.
## Editor ToolBar

In the table below, the first image shows the appearance of the toolbutton with Native Look and Feel enabled; the second with it disabled.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Toggle line numbers" /></td>
<td>Toggles Line numbers on/off</td>
</tr>
<tr>
<td><img src="image" alt="Toggle tree view" /></td>
<td>Toggles the treeview on/off. See <a href="#">Editing Classes on page 140</a>.</td>
</tr>
<tr>
<td><img src="image" alt="Previous Location" /></td>
<td>Certain operations (such as selecting an item in the treeview) reposition the caret in the Editor window. This button moves the caret back to its previous location.</td>
</tr>
<tr>
<td><img src="image" alt="Comment selected text" /></td>
<td>Inserts a comment symbol to the left of the selection in each of the selected lines.</td>
</tr>
<tr>
<td><img src="image" alt="Uncomment selected text" /></td>
<td>Removes the comment symbol (if present) from the left-most column of the selection in each of the selected lines.</td>
</tr>
<tr>
<td><img src="image" alt="Save changes and return" /></td>
<td>Saves changes and closes the current edit window</td>
</tr>
<tr>
<td><img src="image" alt="Search Box" /></td>
<td>Enter search text and click one of the following two buttons</td>
</tr>
<tr>
<td><img src="image" alt="Search for Next Match" /></td>
<td>Locates the next occurrence of the search text</td>
</tr>
</tbody>
</table>
## Button

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Search for Previous Match" /></td>
<td>Locates the previous occurrence of the search</td>
</tr>
<tr>
<td><img src="image" alt="Search hidden text" /></td>
<td>Determines whether or not the search examines collapsed blocks</td>
</tr>
<tr>
<td><img src="image" alt="Match case" /></td>
<td>Specifies whether or not the search is case-sensitive</td>
</tr>
<tr>
<td><img src="image" alt="Match whole word" /></td>
<td>Specifies whether or not the search matches a whole word</td>
</tr>
<tr>
<td><img src="image" alt="Use Regular Expressions" /></td>
<td>Specifies whether or not the search uses PCRE regular expressions</td>
</tr>
<tr>
<td><img src="image" alt="Refactor text as method" /></td>
<td>Inserts a Method template for the selected name</td>
</tr>
<tr>
<td><img src="image" alt="Refactor text as field" /></td>
<td>Inserts a Field template for the selected name</td>
</tr>
<tr>
<td><img src="image" alt="Refactor text as property" /></td>
<td>Inserts a Property template for the selected name</td>
</tr>
</tbody>
</table>
The File Menu

The *File* menu illustrated above is displayed when editing a simple object and provides the following options.
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fix</td>
<td>Fixes the object in the workspace, but leaves the edit window open. Edit history is also preserved. If the data has changed and the <code>confirm_fix</code> parameter is set, you will be prompted to confirm.</td>
</tr>
<tr>
<td>Fix whole script</td>
<td>(Disabled unless editing a script)</td>
</tr>
<tr>
<td>Open File</td>
<td>Allows you to edit a Dyalog script file or an arbitrary text file.</td>
</tr>
<tr>
<td>Save</td>
<td>Saves the file being edited.</td>
</tr>
<tr>
<td>Save As</td>
<td>Renames and saves the file being edited.</td>
</tr>
<tr>
<td>Always ask on close</td>
<td>Toggles the value of the <code>confirm_fix</code> parameter.</td>
</tr>
<tr>
<td>Edit</td>
<td>Opens an Edit window on the name under the cursor (Disabled when there is no such name).</td>
</tr>
<tr>
<td>Print</td>
<td>Prints the current contents of the edit window</td>
</tr>
<tr>
<td>Print Setup</td>
<td>Displays the <code>Print Configuration</code> dialog box</td>
</tr>
<tr>
<td>Properties</td>
<td>Displays the <code>Object Properties</code> dialog box for the current object</td>
</tr>
<tr>
<td>Exit (and Fix)</td>
<td>Fixes the object in the workspace and closes the edit window. If the data has changed and the <code>confirm_exit</code> parameter is set, you will be prompted to confirm</td>
</tr>
<tr>
<td>Exit (and fix script)</td>
<td>(Disabled unless editing a script)</td>
</tr>
<tr>
<td>Exit and discard changes</td>
<td>Closes the edit window, but does not fix the object in the workspace. If the data has changed and the <code>confirm_abort</code> parameter is set, you will be prompted to confirm.</td>
</tr>
</tbody>
</table>
The File Menu (editing a script)

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fix whole script</td>
<td>Fixes the entire script</td>
</tr>
<tr>
<td>Fix only functions</td>
<td>Fixes only the functions in the script.</td>
</tr>
<tr>
<td>Exit and fix whole script</td>
<td>Fixes the entire script, and exits the Editor.</td>
</tr>
<tr>
<td>Exit and fix only functions</td>
<td>Fixes only the functions in the script and exits the Editor.</td>
</tr>
</tbody>
</table>
Editing Scripts

Suppose that you have a Class that manages a list of items in a shared Field, so somewhere in the script would appear a line such as:-

```
:Field shared public List←⍬
```

You run your application for a bit, and List, which was initially empty, gets updated as new instances of the Class are created. You then edit the Class to add a new function, or fix a bug. In this instance, when you exit the editor you may not want List to be reset back to the empty vector although you do want the new version of the function(s) in the Class to be fixed.

Nevertheless whenever you edit the Class when it is not suspended, you probably always want the entire script to be re-fixed, and List re-initialised.

The options in the File menu shown above provide for these alternatives.

In addition, the Configuration Dialog (see Installation & Configuration Guide: Configuration Dialog: Trace/Edit Tab) allows you to define the behaviour of the keystrokes <EP> and <S1> for both the suspended case and the non-suspended case. This association will be displayed against the appropriate action according to the state of the script you are editing.
The Edit Menu

The *Edit* menu provides a means to execute those commands that are concerned with editing text. The Edit menu and the actions it provides are described below.

<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcuts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reformat</td>
<td>Num divide</td>
</tr>
<tr>
<td>Reformat Scripts</td>
<td>Control+Shift+Back</td>
</tr>
<tr>
<td>Automatically</td>
<td>Control+Shift+Enter</td>
</tr>
<tr>
<td>Undo</td>
<td>Shift+Delete</td>
</tr>
<tr>
<td>Redo</td>
<td>Control+Insert</td>
</tr>
<tr>
<td>Select All</td>
<td>Shift+Insert</td>
</tr>
<tr>
<td>Copy</td>
<td>Control+Insert</td>
</tr>
<tr>
<td>Paste</td>
<td>Shift+Insert</td>
</tr>
<tr>
<td>Paste Unicode</td>
<td></td>
</tr>
<tr>
<td>Paste Non-Unicode</td>
<td></td>
</tr>
<tr>
<td>Clear</td>
<td>Delete</td>
</tr>
<tr>
<td>Open Line</td>
<td></td>
</tr>
<tr>
<td>Delete Line</td>
<td>Control+Delete</td>
</tr>
<tr>
<td>Goto Line</td>
<td></td>
</tr>
<tr>
<td>Find...</td>
<td></td>
</tr>
<tr>
<td>Replace...</td>
<td></td>
</tr>
<tr>
<td>Highlight All Matches</td>
<td></td>
</tr>
<tr>
<td>Comment Selected Lines</td>
<td></td>
</tr>
<tr>
<td>Uncomment Selected Lines</td>
<td></td>
</tr>
<tr>
<td>Toggle Local Name</td>
<td>Control+Up</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Reformat</td>
<td>Reformats the function body in the edit window, indenting control structures as appropriate.</td>
</tr>
<tr>
<td>Reformat Scripts</td>
<td>If checked, the Editor will automatically reformat a Dyalog script when it loads it.</td>
</tr>
<tr>
<td>Automatically</td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Undoes the last change made to the object. Repeated use of this command sequentially undoes each change made since the edit window was opened.</td>
</tr>
<tr>
<td>Redo</td>
<td>Re-applies the previous undone change. Repeated use of this command sequentially restores every undone change.</td>
</tr>
<tr>
<td>Select All</td>
<td>Selects and highlights the entire contents of the Edit window.</td>
</tr>
<tr>
<td>Cut</td>
<td>Copies the selected text to the clipboard and removes it from the object.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the selected text to the clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>Copies the text in the clipboard into the object at the current location of the input cursor.</td>
</tr>
<tr>
<td>Paste Unicode</td>
<td>Same as Paste, but gets the Unicode text from the clipboard and converts to ⎕AV.</td>
</tr>
<tr>
<td>Paste Non-Unicode</td>
<td>Same as Paste, but gets the ANSI text from the clipboard and converts to ⎕AV.</td>
</tr>
<tr>
<td>Clear</td>
<td>Deletes the selection or the character under the cursor. Has no effect on the clipboard.</td>
</tr>
<tr>
<td>Open Line</td>
<td>Inserts a blank line immediately below the current one.</td>
</tr>
<tr>
<td>Delete Line</td>
<td>Deletes the current line.</td>
</tr>
<tr>
<td>Goto Line</td>
<td>Prompts for a line number, then positions the cursor on that line.</td>
</tr>
<tr>
<td>Find</td>
<td>Displays the Find dialog box.</td>
</tr>
<tr>
<td>Replace</td>
<td>Displays the Replace dialog box.</td>
</tr>
<tr>
<td>Highlight All Matches</td>
<td>If checked, all strings in the object being edited that match the search string are highlighted. The highlighted items change dynamically as the search string is entered or changed.</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Comment selected lines</td>
<td>Adds a comment symbol to the beginning of all selected lines.</td>
</tr>
<tr>
<td>Uncomment selected lines</td>
<td>Removes a comment symbol from the beginning of all selected lines.</td>
</tr>
<tr>
<td>Toggle Local name</td>
<td>Adds or removes the name under the cursor to/from the function header line.</td>
</tr>
</tbody>
</table>

The *Find* and *Replace* items are used to display the *Find* dialog box and the *Find/Replace* dialog box respectively. These boxes are used to perform search and replace operations and are described later in this Chapter.

Once displayed, each of the two dialog boxes remains on the screen until it is either closed or replaced by the other. This is convenient if the same operations are to be performed over and over again, and/or in several windows. *Find* and *Find/Replace* operations are effective in the window that previously had the focus.

### The Syntax Menu

The *Syntax* menu illustrated above provides options to specify how the data displayed in the Editor window is to be syntax coloured. For workspace objects, the default is *APL* for functions and operators, and *Nothing* for variables.

<table>
<thead>
<tr>
<th>Item</th>
<th>Syntax Colour as</th>
</tr>
</thead>
<tbody>
<tr>
<td>Nothing</td>
<td>Variable</td>
</tr>
<tr>
<td>APL</td>
<td>Function</td>
</tr>
<tr>
<td>JSON</td>
<td>JSON array</td>
</tr>
<tr>
<td>XML</td>
<td>XML array</td>
</tr>
</tbody>
</table>
The Window Menu

The *Window* menu provides a means to control the display of the various edit windows. The *Window* menu and the actions it provides are described below.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close All Windows</td>
<td>Closes all the edit windows. If <em>Confirm on Edit Window Closed</em> is checked, you will be prompted to confirm for any objects that you have changed.</td>
</tr>
<tr>
<td>Cascade</td>
<td>Arranges the edit windows in overlapping fashion.</td>
</tr>
<tr>
<td>Tile Vertically</td>
<td>Arranges the edit windows tiled one above the other.</td>
</tr>
<tr>
<td>Tile Horizontally</td>
<td>Arranges the edit windows tiled alongside one another.</td>
</tr>
<tr>
<td>Arrange Icons</td>
<td>Arranges any minimised edit windows.</td>
</tr>
<tr>
<td>Editor</td>
<td>Allows you to Select the edit window corresponding to the named object.</td>
</tr>
</tbody>
</table>
The Refactor Menu

The *Refactor* menu illustrated above applies only when editing a Class and provides the following options. In each case, the user must highlight a name in the Edit window, and then select one of these options to insert the appropriate template for that name into the body of the Class.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add text as Field</td>
<td>Inserts a Field template for the selected name.</td>
</tr>
<tr>
<td>Add text as Property</td>
<td>Inserts a Property template for the selected name.</td>
</tr>
<tr>
<td>Add text as Method</td>
<td>Inserts a Method template for the selected text name.</td>
</tr>
</tbody>
</table>
The View Menu

The View menu, illustrated above, provides the following actions.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trace</td>
<td>Displays a column to the left of the function that displays ⎕TRACE settings.</td>
</tr>
<tr>
<td>Stop</td>
<td>Displays a column to the left of the function that displays ⎕STOP settings.</td>
</tr>
<tr>
<td>Monitor</td>
<td>Displays a column to the left of the function that displays ⎕MONITOR settings.</td>
</tr>
<tr>
<td>Line Numbers</td>
<td>Toggles the display of line numbers on/off.</td>
</tr>
<tr>
<td>Function Line Numbers</td>
<td>Toggles the display of line numbers on individual functions on/off. This option is only enabled when editing a Class, Namespace script or Interface.</td>
</tr>
<tr>
<td>Tree View</td>
<td>Toggles the display of the treeview in the left-hand pane.</td>
</tr>
<tr>
<td>Compiler Errors</td>
<td>If enabled, the Editor identifies which lines of code would not compile. These are identified by a red vertical line to the left. Hovering over the red bar gives you a pop-up telling you what the compiler didn't like about that line of the function.</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Outlining</td>
<td>Turns outlining on and off.</td>
</tr>
<tr>
<td>Expand All Outlines</td>
<td>Expands all outlines.</td>
</tr>
<tr>
<td>Collapse All Outlines</td>
<td>Collapses all outlines.</td>
</tr>
<tr>
<td>Expand all Outlines below here</td>
<td>Expands all outlines below the level of the current line.</td>
</tr>
</tbody>
</table>

**Function Line Numbers**

The *Function Line Numbers* option in the Editor menu provides an additional level of line-numbering. If selected, line numbers are displayed *independently* on each individual function (or operator) in the Class. This option is only enabled when you are editing a Class, Namespace script or Interface, and is disabled for all other types of object.

Note that function line-numbering and general line-numbering are independent options and it is possible to have the entire Class numbered (from [0] to the number of lines in the Class) in addition to having line-numbering on each individual function.
Using the Editor

Creating a New Function

Type the name of your function and invoke the editor. To do this you may press Shift+Enter, or select Edit from the Action menu, or double-click the left button on your mouse, or click the Edit tool in the tool bar. A new window will appear on the screen with the name you have chosen displayed in the top border. The name is also inserted in the function header and the cursor positioned to the right. The new window is automatically given the input focus.

Line-Numbers on/off

Try changing the line numbers setting by clicking on the Line Numbers option in the Options menu. Note that line-numbering on/off is effective for all edit windows.

Adding Lines

If the keyboard is in Insert mode, pressing Enter at the end of a line opens you a new blank line under the current one and positions the cursor there ready for input. You can also open a new blank line by pressing Ctrl+Shift+Insert (OP).

If the cursor is at the end of the last line in the function, pressing Enter adds another line even if the keyboard is in Replace mode.

Indenting Text

Dyalog APL allows you to insert leading spaces in lines of a function and (unless the AutoFormat parameter is set) preserves these spaces between editing sessions. Embedded spaces are however discarded. You can enter spaces using the space bar or the Tab key. Pressing Tab inserts spaces up to the next tab stop corresponding to the value of the TabStops parameter. If the AutoIndent parameter is set, new lines are automatically indented the same amount as the preceding line.

Reformatting

The RD command (which by default is mapped to Keypad-Slash) reformats a function according to your AutoFormat and TabStops settings. See Installation & Configuration Guide: Configuration Dialog: Trace/Edit Tab.

Deleting Lines

To delete a block of lines, select them by dragging the mouse or using the keyboard and then press Delete or select Clear from the Edit menu. A quick way to delete the current line without selecting it first is to press Ctrl+Delete (DK) or select Delete Line from the Edit menu.
Chapter 1: The APL Environment

Copying Lines

Select the lines you wish to copy by dragging the mouse or using the keyboard. Then press Ctrl+Insert or select Copy from the Edit menu. This action copies the selection to the clipboard. Now position the input cursor where you wish to make the copy and press Shift+Insert, or select Paste from the Edit menu. You can also use this method to duplicate a ragged block of text.

To copy text using drag-and-drop editing:

1. Select the text you want to move.
2. Hold down the Ctrl key, point to the selected text and then press and hold down the left mouse button. When the drag-and-drop pointer appears, drag the cursor to a new location.
3. Release the mouse button to drop the text into place.

Moving Lines

Select the lines you wish to copy by dragging the mouse or using the keyboard. Then press Shift+Delete or select Cut from the Edit menu. This action copies the selection to the clipboard and removes it. Now position the input cursor at the new location and press Shift+Insert, or select Paste from the Edit menu. You can also use this method to move a ragged block of text.

To move text using drag-and-drop editing:

1. Select the text you want to move.
2. Point to the selected text and then press and hold down the left mouse button. When the drag-and-drop pointer appears, drag the cursor to a new location.
3. Release the mouse button to drop the text into place.

Joining and Splitting Lines

To join a line to the previous one: select Insert mode; position the cursor on the first character in the line; press Bksp.

To split a line: select Insert mode; position the cursor at the place you want it split; press Return.

Toggling Localisation

The TL command (which by default is mapped to Ctrl+Up) toggles the localisation of the name under the cursor. If the name is currently global, pressing Ctrl+Up causes the name to be added to the list of locals in the function header. If the name is already localised, pressing Ctrl+Alt+l removes it from the header.
Matching Occurrences

When you position the caret over a name, control word, or simple text or to the right of a parenthesis, bracket, or brace, matching occurrences are identified (by a thin box). In particular:

- matching occurrences of the word under the caret (except the actual instance under the caret)
- matching parentheses, brackets and braces
- all control words associated with the one under the caret. For example, if the caret is on :If, then nested :AndIf, :OrIf, :Else and the final :EndIf are identified.

Aligning Comments

When you press the <AC> key, or select Align Comments in the Editor's context menu, the alignment of the comments in every line in the function will be changed so that the left-most comment (Lamp) symbol is in the same column as the cursor, except that:

- Comment symbols that are preceded only by white space, i.e. comments in lines that contain no code, are ignored and are not adjusted in any way.
- Comment symbols that lie between the first column and the first tab stop will remain in or be moved to the first column. For information on setting tab stops, see Installation & Configuration Guide: Configuration Dialog (Edit/Trace Tab).
- Comment symbols will not move further left than the end of the statement.

When a comment is re-aligned, text to the right of the left-most comment symbol (including spaces and other comment symbols) will remain fixed in relation to that symbol.

Note that there is no keystroke associated with this command by default; the user must define one. See Installation & Configuration Guide: Configuration Dialog (Keyboard Shortcuts Tab).
Stop, Trace and Monitor Controls

If any of the Stop, Trace, and Monitor options of the View menu are set, the Editor displays an area to the left of the function body containing up to 3 columns. If a function line is enabled by ⎕TRACE, ⎕STOP or ⎕MONITOR the corresponding column displays a yellow circle (trace), red circle (stop) or clock symbol (monitor).

When you move the mouse-pointer over this area, the pointer displays the appropriate symbol and you can toggle the corresponding setting on and off by clicking the mouse.

White Space in Source Code

Settings that impact the automatic reformatting of code can cause changes to whitespace – this can be interpreted as changes to the source code. This means that:

- opening a scripted object in the Edit window can cause the source of that object to change (when closing an Edit window, you might be prompted to save a function even though you have not made any changes to it).
- viewing an object can change its file timestamp; source code management systems can subsequently report changes due to the changed file timestamp.
- source code changes resulting from reformatting will be evident in the results of system functions such as ⎕AT, ⎕SRC, ⎕CR, ⎕VR and ⎕NR.
Outlining

When you are editing a function, outlining identifies the blocks of code within control structures, and allows you to collapse and expand these blocks so that you can focus your attention on particular parts of the code.

The picture below shows the result of opening the function `SE.cbtop.TB_POPUP`.

![Outlining example](image)

Notice that the various control structure blocks are delineated by a treeview diagram.

- When you hover the mouse pointer over one of the boxes that mark the start of a block, the line marking the extent of that block becomes highlighted, as shown above.
- If you click on a box, the corresponding section collapses, so that only the first line of the block is displayed, as shown below.
- If you click on a box, the corresponding section is expanded.
Chapter 1: The APL Environment

136

{FLAG}TB_POPUP MSG; TC
A Popup menu on Session ToolControl
:If 0=NC FLAG'
   :If (Z=Z=MSG) A Right mouse button ?
   :Else
      TC+ 'bandtb1.tb' 'bandtb2.tb' 'bandtb3.tb' 'bandtb4.tb'
      :Select FLAG
      :Case 1
         ShowCaptions→ShowCaptions
         TC W SYS "ShowCaptions" ShowCaptions
      :Case 2
         Style+(FlatList Style) Style 'FlatList' FlatButtons
         TC W SYS "Style" Style
      :Case 3
         MultiLine→MultiLine
         TC W SYS "MultiLine" MultiLine
   :End
:End
Sections

Functions and scripted objects (classes, namespaces etc.) can be subdivided into Sections with :Section and :EndSection statements. Both statements may be followed by an optional and arbitrary name or description. The purpose is to split the function up into sections that you can open and close in the Editor, thereby aiding readability and code management. Sections have no effect on the execution of the code, but must follow the nesting rules of other control structures.

The following picture illustrates the use of sections in a function called DumpWindow. The function is divided into 5 sections named Comments, Init, NAs, MakeBitmap and CopyToClipboard.

The first picture shows the function with all sections closed.
The next picture shows the effect of opening the Comments section. Notice how this is delineated by the statements:

```
:Section Comments
...
:EndSection Comments
```

And with the Init section opened too:
Finally, with all the sections opened:
Editing Classes

The picture below shows the result of opening the `ComponentFile` class. Notice how each function is delineated separately and that each function is individually line-numbered.

```apl
class ComponentFile
def Private Instance tie

def Private instance temp=0 A Temporary

tie-1劲ml-1

Open filename
   Open Named File

Implements Constructor
Access Public Instance

Trap 0
   tie-filename OFSTIE 0

Else
   DFUNTIIE filename OFCREATE 0 A Create a
   tie=filename OFSTIE 0 A Then sha

EndTrap

OpenTemp:OUSTIIE:
   Default: Open temporary file
Implements Constructor
Access Public Instance

USING=''
   System.IO.Path.GetTempFileName
   ERASE z NTIE 0 A Erase the temp file
   tie=Z OFCREATE 0
   temp=1

Close
Implements Destructor
If tie=OZUMS
   If temp = Name ERASE tie
Else 0 DFUNTIIE tie
EndIf
If temp = Name
   EndIf

End
```

)}ed ComponentFile
The outlining feature really comes into its own when editing classes because you can collapse and expand whole functions. The picture below shows the effect of collapsing all but the `Append` method.
When you edit a class, a separate treeview is optionally displayed in the left pane to make it easy to navigate within the class. When you click on a name in the treeview, the editor automatically scrolls the appropriate section into view (if necessary) and positions the edit cursor at its start. The picture below illustrates the result of opening the [Methods] section and then clicking on Rename.
Sections within Scripts

Scripts can also be subdivided into Sections using :Section and :EndSection statements. As with single functions, the purpose is only to split the script up into sections that you can open and close in the Editor. Sections have no effect on the execution of the code.

The following picture illustrates a Class named actuarial which, for editing purposes, has been sub-divided into five separate Sections named Main, MenuHandlers, Validation, Utilities and OldCode. In this picture, all the Sections are closed.
The next picture shows the effect of opening just the Main section.

Notice that this section is delimited by the two statements:

```apl
:Section Main
...
:EndSection Main
```

In this picture the 3 functions within the Main section are temporarily closed.

Similarly, the section called Validation is delimited by:

```apl
:Section Validation
...
:EndSection Validation
```
Chapter 1: The APL Environment
Find and Replace Dialogs

The *Find* and *Find/Replace* dialog boxes are used to locate and modify text in an Edit window.
| **Search For** | Enter the text string that you want to find. Note that the text from the last 10 searches is available from the drop-down list. If appropriate, the search text is copied from the Find Objects tool. This makes it easy to first search for functions containing a particular string, and then to locate the same string in the functions. |
| **Replace With** | Enter the text string that you want to use as a replacement. Note that the text from the last 10 replacements is available from the drop-down list. |
| **Match Case** | Check this box if you want the search to be case-sensitive. |
| **Match Whole Word** | Check this box if you want the search to only match only whole words. |
| **Use Regular Expressions** | Check this box if you want to use Regular Expressions. |
| **Move Dialog if Hiding Match** | If checked, the *Find* or *Find/Replace* dialog box will automatically position itself so as not to obscure a matched search string in the edit window. |
| **Find Next After Replace** | If checked, following a replace operation, the selection will move to the next occurrence of the target string in the edit window. |
| **Direction** | Select *Up* or *Down* to control the direction of search. |
Using Find and Replace

Find and Replace work on the concept of a current search string and a current replace string which are entered using the Find and Find/Replace Dialog boxes. These boxes also contain buttons for performing search/replace operations.

Suppose that you want to search through a function for references to the string "Adam". It is probably best to work from the start of the function, so first position the cursor there (by pressing Ctrl+Home). Then select Find from the Edit menu. The Find Dialog box will appear on your screen with the input cursor positioned in the edit box awaiting your input. Type "Adam" and click the Find Next button (or press Return), and the cursor will locate the first occurrence. Clicking Find Next again will locate the second occurrence. You can change the direction of the search by selecting Up instead of Down. You could search another function for "Adam" by opening a new Edit window for it and clicking Find Next. You do not have to redefine the search string.

Now let us suppose that you wish to replace all occurrences of "Adam" with "Amanda". First select Replace from the Edit menu. This will cause the Find Dialog box to be replaced by the Find/Replace Dialog box. Enter the string "Amanda" into the box labelled Replace With, then click Replace All. All occurrences of "Adam" in the current Edit window are changed to "Amanda". To repeat the same global change in another function, simply open an edit window and click Replace All again. If instead you only want to change particular instances of "Adam" to "Amanda" you may use Find Next to locate the ones you want, and then Replace to make each individual alteration.

Text searches are performed using PCRE. If the Use Regular Expressions box is checked, the full range of regular expressions provided by PCRE are available for use. See Language Reference Guide: Appendix A.

Saving and Quitting

To save the function and terminate the edit, press Esc (EP) or select Exit from the File menu. The new version of the function replaces the previous one (if any) and the edit window is destroyed.

Alternatively, you can select Fix from the File menu. This fixes the new version of the function in the workspace, but leaves the edit window open. Note that the history is also retained, so you can subsequently undo some changes and fix the function again.

To abandon the edit, press Shift+Esc (QT) or select Abort from the File menu. This destroys the edit window but does not fix the function. The previous version (if any) is unchanged.
Editing Scripts and Text Files

The Editor may also be used to edit Dyalog script files (`.dyalog` files) and general text files.

There are two ways to choose the file to be edited. If the file exists, you can select it from the Open source file dialog by clicking File/Edit Text File from the Session menu bar.

Alternatively, type `)ED` followed by the pathname to the file. To identify the name given as a file, it must either contain a slash character ("\" or "/") or be preceded by one.

Examples

```
)ED c:\myfiles\myscript.dyalog
)ED c:\myfiles\pete.txt
)ED \x.txt  A x.txt in current directory
)ed / x.txt A ditto
```

If the named file does not exist, you will be asked whether or not you want to create it:

![Message dialog]

If you edit a Dyalog script file, the editor will treat it as such and provide the same formatting and syntax colouring as if it were a script in the workspace.

Otherwise, the file will be edited as if it were a character vector with embedded newlines.

When you exit the editor with Exit and fix, you will be offered a number of alternatives depending upon the type of file, as shown below.
Saving a Text file.

Note that if you choose *Save as text in the workspace*, information about the file and the text variable associated with it is retained in the workspace. This information may be obtained using `5176` and `5177`. See *Language Reference Guide: List Loaded Files* and *List Loaded File Objects*. 

[Image of Dyalog APL/W-64 Overwrite file dialog box]
Saving a Script file.

Note that if you choose *Fix as code in the workspace* or *Save as text in the workspace*, information about the file and the text variable associated with it is retained in the workspace. This information may be obtained using 5176 and 5177. See *Language Reference Guide: List Loaded Files* and *List Loaded File Objects*. 
Fix as code in the workspace

If you choose this option, the file will be updated and the script will also be fixed in the workspace. Note that if the script refers to a base class or other external elements, it cannot be fixed unless these elements are also present in the workspace.

Save as text in the workspace

If you choose this option, the file will be updated and the contents of the file will also be saved to a variable in the workspace. First you will see the following warning dialog, which may be disabled subsequently by checking Do not ask this question again.

Then you will be prompted to supply its name, which may be a new name or the name of an existing variable:

Only save file to disk

If you choose this option, the file will be updated but nothing will be changed in the workspace.

Discard changes

If you choose this option, all changes will be discarded and nothing saved.
The Tracer

The Tracer is a visual debugging aid that allows you to step through an application line by line. During a Trace you can track the path taken through your code, display variables in edit windows and watch them change, skip forwards and backwards in a function. You can cutback the stack to a calling function and use the Session and Editor to experiment with and correct your code. The Tracer may be invoked in several ways as discussed below.

Tracing an expression

Firstly, you may explicitly trace an expression that executes one or more defined functions or operators by typing the expression then pressing Ctrl+Enter (TC) or by selecting Trace from the Action menu. This lets you step through the execution of an expression from the beginning.

In the same way as when you execute a statement by pressing Enter, the expression is (if necessary) copied down to the input line and then executed. However, if the expression includes a reference to an unlocked defined function or operator, execution halts at its first line and a Trace window containing the suspended function or operator is displayed on the screen. The cursor is positioned to the left of the first line which is highlighted.

Naked Trace

The second way to invoke the Tracer is when you have a suspended function in the state indicator and you press Ctrl+Enter (TC) on the empty input line. This is termed naked trace. The same thing can be achieved by selecting Trace from the Action menu on the Session Window.

The effect of naked trace is to open the Tracer and to position the cursor on the currently suspended line. It is exactly as if you had traced to that point from the Input Line expression whose execution caused the suspension.

Automatic Trace

The third way to invoke the Tracer is to have the system do it automatically for you whenever an error occurs. This is achieved by setting the Show trace stack on error option in the Trace/Edit tab of the Configuration dialog (Trace_on_error parameter). When an error occurs, the system will automatically deploy the Tracer. Note that this means that when an error occurs, the Trace window will then receive the input focus and not the Session window.
Tracer Options

From Version 10.1 onwards, the Tracer is designed to be docked in the Session window.

In previous versions of Dyalog APL, the Tracer was implemented as a stack of separate windows (one per function on the calling stack) or as a single, but still separate, window.

You can disable the standard behaviour by selecting Classic Dyalog mode from the Trace/Edit tab of the Configuration dialog box.

If you do so, you may then choose to have the Tracer operate in multiple windows or in a single window.

These alternatives are discussed later in this Chapter.

The Trace Window

The Tracer is implemented as a single dockable window that displays the function that is currently being executed. There are two subsidiary information windows which are also fully dockable. The first of these (SIS) displays the current function calling stack; the second (Threads) displays a list of running threads.

In the default Session files, the Tracer is docked along the bottom edge of the Session window. When you invoke the Tracer, it springs up as illustrated below. In this example, the function being traced is ⍪SE.UCMD, which is invoked by typing a user-command, in this case ⍬DISPLAY.

In the default layout, the SIS stack window is displayed alongside the main Tracer window, although this can be hidden or made to appear as a separate floating window, as required.
Trace Tools

The Tracer may be controlled from the keyboard, or by using the Trace Tools which are arranged along the title bar of the Debugger window. Note that the button names are solely for reference purposes in the description that follows.

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Key Code</th>
<th>Keystroke</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Exec</td>
<td>ER</td>
<td>Enter</td>
<td>Execute expression</td>
</tr>
<tr>
<td></td>
<td>Trace</td>
<td>TC</td>
<td>Ctrl+Enter</td>
<td>Trace expression</td>
</tr>
<tr>
<td></td>
<td>Back</td>
<td>BK</td>
<td>Ctrl+Shift+Bksp</td>
<td>Go back one line</td>
</tr>
<tr>
<td></td>
<td>Fwd</td>
<td>FD</td>
<td>Ctrl+Shift+Enter</td>
<td>Skip current line</td>
</tr>
<tr>
<td></td>
<td>Continue</td>
<td>BH</td>
<td></td>
<td>Stop on next line of calling function</td>
</tr>
<tr>
<td></td>
<td>Restart</td>
<td>RM</td>
<td>→⎕LC</td>
<td>Continue execution of this thread</td>
</tr>
<tr>
<td></td>
<td>Restart all</td>
<td></td>
<td></td>
<td>Continue execution of all threads</td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td>ED</td>
<td>Shift+Enter</td>
<td>Edit name</td>
</tr>
<tr>
<td></td>
<td>Exit</td>
<td>EP</td>
<td>Esc</td>
<td>Quit this function</td>
</tr>
<tr>
<td></td>
<td>Intr</td>
<td>Ctrl+Pause</td>
<td></td>
<td>Interrupt</td>
</tr>
</tbody>
</table>
### Button: Name: Key Code: Keystroke: Description:

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Key Code</th>
<th>Keystroke</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Reset</td>
<td>CB</td>
<td>Clear</td>
<td>trace/stop/monitor for this object</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>LN</td>
<td></td>
<td>Search for next match</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Search for previous match</td>
<td></td>
<td>Search for previous match</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Search hidden text</td>
<td></td>
<td>Search hidden text</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Match case</td>
<td></td>
<td>Match case</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Match whole word</td>
<td></td>
<td>Match whole word</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td>Use Regular Expressions</td>
<td></td>
<td>Use Regular Expressions</td>
<td></td>
</tr>
</tbody>
</table>

Using the Trace Tools, you can **single-step** through the function or operator by clicking the *Exec* and/or *Trace* buttons. If you click *Exec* the current line of the function or operator is executed and the system halts at the next line. If you click *Trace*, the current line is executed but any defined functions or operators referenced on that line are themselves traced. After execution of the line the system again halts at the next one. Using the keyboard, the same effect can be achieved by pressing Enter or Ctrl+Enter.

The illustration below shows the state of execution having clicked *Exec* 16 times to reach `[SE.UCMD[17]`.
Execution Reached ⎕SE.UCMD[35]

The next illustration shows the result of clicking Trace at this point. This caused the system to trace into ⎕SE.SaltUtils.Spice, the function called from ⎕SE.UCMD[35].

Notice how each function call on the stack is represented by an item in the Slstack window.
Execution Reached ⎕SE.SALTUtils.Spice[1]
The illustration below shows the state of execution having traced deeper into the system.

Execution reached four levels deep

At this stage, the state indicator is as follows:

\[\)SI
\[\[\text{SE.SALT.Load[1]*}
\[\[\text{SE.SALTUtils.Spice[249]}
\[\[\text{SE.UCMD[35]}
\]
Controlling Execution

The point of execution may be moved by clicking the Back and Fwd buttons in the Trace Tools window or, using the keyboard, by pressing Ctrl+Shift+Bksp and Ctrl+Shift+Enter. Notice however that these buttons do not themselves change the state indicator or the display in the SIStack window. This happens only when you restart execution from the new point.

You can cut back the stack by clicking the <EP> button in the Trace Tools window. This causes execution to be suspended at the start of the line which was previously traced. The same effect can be achieved using the keyboard by pressing Esc. It can also be done by selecting Exit from the File menu on the Trace Window or by selecting Close from its system menu.

The <RM> button removes the Trace window and resumes execution. The same is achieved by the expression ←L.C.

The <BH> button continues execution until the current function has run to completion and control has returned to the calling function. It leaves the Trace window displayed and allows you to watch execution progress.

Using the Session and the Editor

Whilst using the Tracer you can skip to the Session or to any Edit window and back again. While it is docked, you may resize the Tracer pane by dragging its title bar, and you may use the buttons provided to maximise, minimise and restore the Tracer pane within the Session window.

Unless you move it, the cursor is positioned to the left of the suspended line in the top Trace window.

Depending where the cursor is in the tracer window, pressing Shift+Enter (ED) or selecting Edit from the File menu may cause an edit window to open. If the cursor is in the first column of the Trace window, or on whitespace, the Editor is opened on function or operator on top of the stack. If the cursor is on a name, the Editor is opened on the name under the cursor (point-and-edit). With the cursor in any other location, no action is undertaken.

When you finish editing, the window reverts to a trace window with the new definition of the function or operator displayed.

You may also open a new edit window from within the Tracer using point-and-edit.

You can copy text from a trace window to the session for editing and execution or for experimentation.

It is possible to skip from the Tracer to the Session and then re-invoke the Tracer on a different expression.
Setting Break-Points

Break-points are defined by ⎕STOP and may be toggled on and off in an Edit or Trace window by clicking in the appropriate column. The example below illustrates a function with a ⎕STOP break-point set on line [5].

⎕STOP break-points set or cleared in an Edit window are not established until the function is fixed. ⎕STOP break-points set or cleared in a Trace window are established immediately.

Clearing All Break-Points

You can clear all break-points by pressing the above button in the Trace Tools window. This in fact resets ⎕STOP for all functions in the workspace.
The Classic mode Tracer

If you select *Classic Dyalog mode* from the *Trace/Edit* tab in the *Configuration* dialog box, the Tracer behaves in the same way as in Dyalog APL Version 8.2. However, the Tracer is not dockable in the Session.

If you select the Classic mode Tracer, you may choose between multiple trace windows or a single trace window using the *Single Trace Window* option.

### Multiple Trace Windows

The following behaviour is obtained by **deselecting** the *Single Trace Window* option.

- Each function on the SI stack is represented by a separate trace window. The top window contains the function that is currently executing, other windows display functions further up the stack, in the order in which they were called.
- When you press Ctrl+Enter or click the *Trace* button on a line that calls another function, a new trace window appears on top of the stack and displays the newly called function.
- When a function exits, its trace window disappears and the focus moves to the previous trace window. When the last function in a traced suspension exits, the last trace window disappears.
- If you click the *Quit this function* button in the *Trace Tools* window, or press Escape, or close the trace window by clicking on its [X] button or typing Alt-F4, the top trace window disappears and the focus moves to the previous trace window.
- If you close any of the trace windows further down the stack, the stack will be cut back to the corresponding point, i.e. to the line of code that called the function whose trace window you closed.
- The `<RM>` button removes all the trace windows and resumes execution. The same is achieved by the expression `→[L C]`. The `<CS>` button also continues execution, but leaves the trace windows displayed and allows you to watch their progress.
- If you minimise any of the trace windows, the entire stack is minimised to a single icon, from which it may be restored.
- If you drag any Trace window with the mouse and at the same time press Ctrl+Shift, the entire set of Trace windows is dragged.

Note that a maximum of 50 Trace windows may be displayed.
Single Trace Window

The following behaviour is obtained by selecting the Single Trace Window option.

- The trace window contains a combo box whose drop-down displays the contents of the SI stack. This box is not provided if there are multiple trace windows.
- The trace window is re-used when tracing into, or returning from, a called function. This means that there is never more than one trace window present.
- When the last function in a traced suspension exits, the trace window disappears.
- If you click the Quit this function button in the Trace Tools window, or press Escape, the current function is removed from the stack and the trace window reused to display the calling function if there is one.
- Closing the trace window by clicking on its [X] button or typing Alt-F4 removes the window and clears the current suspension. It is equivalent to typing naked branch (→) in the session window.
- If you move or resize the trace window, APL remembers its position, so that it reappears in the same position when next used.
The Threads Tool

The Threads Tool is used to monitor and debug multi-threaded applications. To display the Threads Tool, select Show Threads Tool from the Session Threads menu, or Threads from the Session pop-up menu.

The above picture illustrates a situation using the `lift.dws` workspace after executing the function `RUN`. The Pause on Error option was enabled and a Stop was set on `RUN[63]`. When `RUN` suspended at this point, all other threads (1-8) were automatically Paused. Note that all other threads happen to be Paused in the middle of calls to system functions.

The columns of the Threads Tool display the following information.

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tid</td>
<td>The Thread ID (TID) and name (TNAME) if set</td>
</tr>
<tr>
<td>Location</td>
<td>The currently executing line of function code</td>
</tr>
<tr>
<td>State</td>
<td>Indicates what the thread is doing. (see below)</td>
</tr>
<tr>
<td>Flags</td>
<td>Normal or Paused.</td>
</tr>
<tr>
<td>Treq</td>
<td>The Thread Requirements (TREQ)</td>
</tr>
</tbody>
</table>
## Thread States

<table>
<thead>
<tr>
<th>State</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pending</td>
<td>Not yet running</td>
</tr>
<tr>
<td>Initializing</td>
<td>Not yet running</td>
</tr>
<tr>
<td>Defined function</td>
<td>Between lines of a defined function</td>
</tr>
<tr>
<td>Dfn</td>
<td>Between lines of a dfn</td>
</tr>
<tr>
<td>Suspended</td>
<td>Indicates that the thread is suspended and is able to accept input from the Session window.</td>
</tr>
<tr>
<td>Session</td>
<td>Indicates that Session window is connected to this thread.</td>
</tr>
<tr>
<td>(no stack)</td>
<td>Indicates that the thread has no SI stack and the Session is connected to another thread. This state can only occur for Thread 0.</td>
</tr>
<tr>
<td>Exiting</td>
<td>About to be terminated</td>
</tr>
<tr>
<td>:Hold</td>
<td>Waiting for a :Hold token</td>
</tr>
<tr>
<td>:EndHold</td>
<td>Waiting for a :Hold token</td>
</tr>
<tr>
<td>⎕DL</td>
<td>Executing ⎕DL</td>
</tr>
<tr>
<td>⎕DQ</td>
<td>Executing ⎕DQ</td>
</tr>
<tr>
<td>⎕NA</td>
<td>Waiting for a DLL (⎕NA) call to return.</td>
</tr>
<tr>
<td>⎕TGET</td>
<td>Executing ⎕TGET, waiting for a token</td>
</tr>
<tr>
<td>⎕TGET (Ready to continue)</td>
<td>Executing ⎕TGET, having got a token</td>
</tr>
<tr>
<td>⎕TSYNC</td>
<td>Waiting for another thread to terminate</td>
</tr>
<tr>
<td>Awaiting request</td>
<td>Indicates a thread that is associated with a .NET system thread, but is currently unused</td>
</tr>
<tr>
<td>Called .NET</td>
<td>Waiting for a call to .NET to return.</td>
</tr>
</tbody>
</table>
Paused/Normal

In addition to the thread state as described above, a thread may be *Paused* or *Normal* as shown in the Flags column. A *Paused* thread is one that has temporarily been removed from the list of threads that are being scheduled by the thread scheduler. A *Paused* thread is effectively frozen.

**Threads Tool Pop-Up Menu**

![Threads Tool Pop-Up Menu](image)
| **Switch to** | Selecting this item causes APL to attempt to suspend (if necessary) and switch to the selected thread, connecting it to the Session and Debugger windows. |
| **Interrupt** | Causes a (STRONG) interrupt in the selected thread the next time it is scheduled, essentially it allows you to target an interrupt at a specific thread. |
| **Ignore Interrupts** | Allows you to specify that the selected thread should ignore weak interrupts. |
| **Refresh Now** | Refreshes the Threads Tool display to show the current position and state of each thread. |
| **Auto Refresh** | Selecting this item causes the Threads Tool to be updated continuously, so that it shows the latest position and state of each thread. |
| **Pause Threads on Error** | If this item is checked, APL automatically Pauses all other threads when a thread suspends due to an error or an interrupt. |
| **Paused** | This item toggles a thread between being *Paused* and *Normal*. It Pauses a *Normal* thread and resumes a *Paused* thread. |
| **Pause All** | This item causes all threads to be *Paused*. |
| **Resume All** | This item resumes all threads. |
| **Restart All** | This item resumes all *Paused* threads, restarts all suspended threads, and closes the Debugger. |
Debugging Threads

The Debugger provides a tabbed interface that allows you to easily switch between suspended threads for debugging purposes. To keep things simple for non-threaded applications, Tabs are only displayed if there is a thread suspended that is other than Thread 0. The following picture shows the Debugger open on a multi-threaded application (LIFT.DWS) when only Thread 0 is suspended. This has been achieved by setting a stop on RUN[63]
In the next picture, the user has chosen to display the *Threads Tool* and then dock it between the Session and Debugger windows. Note that only one thread, thread 0 (Run) is suspended. All the other threads are *Paused* (because *Pause on Error* is enabled).
The user then uses the context menu to Switch To Thread 14 (whose name is Lady 14) which was Paused on PERSON[7] in the middle of a ⎕TGET. The act of switching to this thread caused it to be suspended at the beginning of its current line PERSON[7] and the Debugger now displays two Tabs to represent the two suspended threads. Note that both the thread id and the thread name are displayed on the Tabs.

Note also that the Session window is connected to the thread indicated by the selected Tab. In this case, typing MYFLOOR into the Session window displays the value of the local variable MYFLOOR in Thread 14 (Lady 14).
You can use the Tabs to switch between the suspended threads, so clicking the Tab labelled 0:Run causes the display to change to the picture shown below. The Session is now connected to Thread 0 (Run), so the value of ⎕LC is 63.
The Event Viewer

The Event Viewer can be used to monitor events on Dyalog APL GUI objects. To display the Event Viewer, select Event Viewer from the Session Tools menu.

You can choose:

- which types of events you want to monitor
- which objects you want to monitor

In the example illustrated above, the user has chosen to monitor events on a Form #.f. Furthermore, the user has chosen to monitor GotFocus, LostFocus, MouseUp, MouseDbClick and Configure events.

Entries in the Action column report the action that was associated with the event at the time it was placed in the queue. This may or may not be the same as the action that is associated with the event when it reaches the top of the event queue and is processed.
The Spy Menu

The Spy menu, illustrated above, provides the following options and actions.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clear</td>
<td>Clears all of the event information that is currently displayed in the <em>Event Viewer</em>.</td>
</tr>
<tr>
<td>Copy</td>
<td>Copies the highlighted rows to the clipboard.</td>
</tr>
<tr>
<td>All</td>
<td>In this mode all the events are displayed in the <em>Event Viewer</em> as they occur, whether or not there is an action associated with them.</td>
</tr>
<tr>
<td>When Placed in Object's Queue</td>
<td>In this mode only events that have associated actions are displayed in the event viewer. Note that KeyPress events are always queued and therefore always appear, even if there is no associated action.</td>
</tr>
<tr>
<td>Current Queue State</td>
<td>In this mode the <em>Event Viewer</em> displays a snapshot of the internal event queue. Only those events that are currently in the internal APL event queue waiting to be processed are displayed.</td>
</tr>
<tr>
<td>Enable Logging</td>
<td>This item switches event logging on and off.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the <em>Event Viewer</em></td>
</tr>
</tbody>
</table>
The Columns Menu

The Columns menu allows you to choose which information is displayed for the events you are monitoring.
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ObjectName</td>
<td>If checked, this item displays the <em>name</em> of the object on which the event occurred.</td>
</tr>
<tr>
<td>ObjectType</td>
<td>If checked, this item displays the <em>type</em> of the object on which the event occurred.</td>
</tr>
<tr>
<td>Event Name</td>
<td>If checked, this item displays the <em>name</em> of the event that occurred.</td>
</tr>
<tr>
<td>Event Number</td>
<td>If checked, this item displays the <em>event number</em> of the event that occurred.</td>
</tr>
<tr>
<td>Parameters</td>
<td>If checked, this item displays the <em>parameters</em> for the event that occurred. These are the items that would be passed in the argument to a callback function.</td>
</tr>
<tr>
<td>Action</td>
<td>If checked, this item displays the <em>action</em> associated with the event when the event is placed in the event queue, for example the name of a callback function, or an expression to be executed.</td>
</tr>
<tr>
<td>Thread ID</td>
<td>If checked, this item displays the <em>thread id</em> of the thread in which the event occurred.</td>
</tr>
<tr>
<td>NQed</td>
<td>If checked, this item displays 0 or 1 according to whether or not the event occurred <em>naturally</em> or was generated programmatically by ⎕NQ.</td>
</tr>
<tr>
<td>Event ID</td>
<td>If checked, this item displays the <em>event id</em> of the event that occurred. This id is used internally.</td>
</tr>
<tr>
<td>TimeStamp</td>
<td>If checked, this item displays the <em>timestamp</em> of the event that occurred.</td>
</tr>
</tbody>
</table>
The Select Menu

The Select menu allows you to highlight certain events in the Event Viewer. For example, if you are monitoring TCP/IP events on a number of TCPSockets, you can highlight just the events for a particular socket.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select All</td>
<td>Highlights all the events.</td>
</tr>
<tr>
<td>Select Matching Events</td>
<td>Highlights all the events that have the same Object and Event Name (or Event Number) as the currently selected event.</td>
</tr>
<tr>
<td>Select All Events on This Object</td>
<td>Highlights all the events that have the same Object as the currently selected event.</td>
</tr>
<tr>
<td>Select All Events of this Type</td>
<td>Highlights all the events that have the same Event Name (or Event Number) as the currently selected event.</td>
</tr>
</tbody>
</table>

These items are also available from the pop-up menu that appears when you press the right mouse button over an event displayed in the Event Viewer window.
The Options Menu

The Options menu allows you to choose which information is displayed for the events you are monitoring.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Always on Top</td>
<td>If checked, this item causes the Event Viewer window to be displayed above all other windows (including other application windows).</td>
</tr>
<tr>
<td>Use APL font</td>
<td>If checked, this item causes the information displayed in the Event Viewer window to be displayed using the APL font (the same font as is used in the Session window). If not, the system uses the appropriate Windows font.</td>
</tr>
<tr>
<td>Settings...</td>
<td>Displays the Event Viewer Options Dialog Box.</td>
</tr>
</tbody>
</table>
Options Dialog Box

The Event Viewer Options dialog box allows you to select the objects and events that you wish to monitor.

Events to view

The list box shows all the events that are support by the Dyalog APL GUI and allows you to select which events are to be monitored. User defined events may be selected by checking the User defined events box. Only those events that are selected will be reported. You can sort the events by name or by event number by clicking the appropriate column header.
## Objects to view

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find Tool</td>
<td>This tool allows you to choose a single specific Dyalog APL GUI object that you want to monitor. To use it, drag the <em>Find Tool</em> and move it over your Dyalog APL GUI objects. As you drag it, the individual objects are highlighted and their details displayed in the <em>Name</em>, <em>Type</em>, <em>Thread ID</em> and <em>Handle</em> fields. Drop the <em>Find Tool</em> on the object of your choice.</td>
</tr>
<tr>
<td>Select from List</td>
<td>Clicking the <em>Select from List</em> button brings up a dialog box that displays the entire Dyalog APL GUI structure as a tree view. You can choose a single object by selecting it.</td>
</tr>
<tr>
<td>Parent Object</td>
<td>Enables event reporting on the selected object's immediate parent.</td>
</tr>
<tr>
<td>Child Objects</td>
<td>Enables event reporting on the all selected object's descendants (at any level).</td>
</tr>
<tr>
<td>Same Thread</td>
<td>Enables event reporting on all the objects in the same thread as the selected object.</td>
</tr>
<tr>
<td>All Objects</td>
<td>Enables event reporting on all Dyalog APL GUI objects.</td>
</tr>
<tr>
<td>Objects of Type</td>
<td>Activates the adjoining <em>Select</em> button and disables all other Object selection mechanisms.</td>
</tr>
<tr>
<td>Select from List</td>
<td>Clicking the <em>Select from List</em> button brings up a dialog box that allows you to choose which types of Dyalog APL GUI objects you want to monitor.</td>
</tr>
</tbody>
</table>


The Session Object

Purpose: The Session object ⎕SE is a special system object that represents the session window and acts as a parent for the session menus, tool bar (s) and status bar.

Children Form, MenuBar, Menu, MsgBox, Font, FileBox, Printer, Bitmap, Icon, Cursor, Clipboard, Locator, Timer, Metafile, ToolBar, StatusBar, TipField, TabBar, ImageList, PropertySheet, OLEClient, TCPSocket, CoolBar, ToolControl, BrowseBox

Properties Type, Caption, Posn, Size, File, Coord, State, Event, FontObj, YRange, XRange, Data, TextSize, Handle, HintObj, TipObj, CurObj, CurPos, CurSpace, Log, Input, Popup, RadiusMode, MethodList, ChildList, EventList, PropList

Methods ChooseFont, FileRead, FileWrite

Events Close, Create, FontOK, FontCancel, WorkspaceLoaded, SessionPrint, SessionTrace

Description

There is one (and only one) object of type Session and it is called ⎕SE. You may use ⎕WG, ⎕WS and ⎕WN to perform operations on ⎕SE, but you cannot expunge it with ⎕EX nor can you recreate it using ⎕WC. You may however expunge all its children. This will result in a bare session with no menu bar, tool bar or status bar.

⎕SE is loaded from a session file when APL starts. The name of the session file is specified by the session_file parameter. If no session file is defined, ⎕SE will have no children and the session will be devoid of menu bar, tool bar and status bar components.

An additional feature is provided to establish code in the Session. See .

You may use all of the standard GUI system functions to build or configure the components of the Session to your own requirements. You may also control the Session by changing certain of its properties.

Note that the Session reports a Create event when APL is first started, and a WorkspaceLoaded event when a workspace is loaded or on a clear ws.

The Session reports a SessionPrint event when certain types of output are about to be displayed. This may be used to alter the normal default display. The Session also reports a event when executing when an expression is execute with trace control. This may be used to alter the normal default trace.
## Read-Only Properties

The following properties of ⍎SE are read-only and may not be set using ⍎WS:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>A character vector containing 'Session'</td>
</tr>
<tr>
<td>Caption</td>
<td>A character vector containing the current caption in the title bar of the Session window.</td>
</tr>
<tr>
<td>TextSize</td>
<td>Reports the bounding rectangle for a text string. For a full description, see TextSize in Object Reference.</td>
</tr>
<tr>
<td>CurObj</td>
<td>A character vector containing the name of the current object. This is the name under or immediately to the left of the input cursor.</td>
</tr>
<tr>
<td>CurPos</td>
<td>A 2-element integer vector containing the position of the input cursor (row and column number) in the session log. This is ⍎IO dependent. If ⍎IO is 1, and the cursor is positioned on the character at the beginning of the first (top) line in the log, CurPos is (1 1). If ⍎IO is 0, its value would be (0 0).</td>
</tr>
<tr>
<td>CurSpace</td>
<td>A character vector which identifies the namespace from which the current expression was executed. If the system is not executing code, CurSpace is the current space and is equivalent to the result of ⊃''⎕NS''.</td>
</tr>
<tr>
<td>Handle</td>
<td>The window handle of the Session window.</td>
</tr>
<tr>
<td>Log</td>
<td>A vector of character vectors containing the most recent set of lines (input statements and results) that are recorded in the session log. The first element contains the top line in the log.</td>
</tr>
<tr>
<td>Input</td>
<td>A vector of character vectors containing the most recent set of input statements (lines that you have executed) contained in the input history buffer.</td>
</tr>
<tr>
<td>ChildList</td>
<td>A vector of character vectors containing the types of object that can be created as a child of ⍎SE.</td>
</tr>
<tr>
<td>MethodList</td>
<td>A vector of character vectors containing the names of the methods associated with ⍎SE.</td>
</tr>
<tr>
<td>EventList</td>
<td>A vector of character vectors containing the names of the events generated by ⍎SE</td>
</tr>
<tr>
<td>PropList</td>
<td>A vector of character vectors containing the names of the properties associated with ⍎SE.</td>
</tr>
</tbody>
</table>
Read/Write Properties

The following properties of ⎕SE may be changed using ⎕WS:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coord</td>
<td>Specifies the co-ordinate system for the session window.</td>
</tr>
<tr>
<td>Data</td>
<td>May be used to associate arbitrary data with the session object ⎕SE.</td>
</tr>
<tr>
<td>Event</td>
<td>You may use this property to attach an expression or callback function to the Create event or to user-defined events. A callback attached to the Create event can be used to initialise the Session when APL starts.</td>
</tr>
<tr>
<td>File</td>
<td>The full pathname of the session file that is associated with the current session. This is the file name used when you save or load the session by invoking the FileRead or FileWrite method.</td>
</tr>
<tr>
<td>FontObj</td>
<td>Specifies the APL font. In general, the FontObj property may specify a font in terms of its face name, size, and so forth or it may specify the name of a Font object. For applications, the latter method is recommended as it will result in better management of font resources. However, in the case of the Session object, it is recommended that the former method be used.</td>
</tr>
<tr>
<td>HintObj</td>
<td>Specifies the name of the object in which hints are displayed. Unless you specify HintObj individually for session components, this object will be used to display the hints associated with all of the menu items, buttons, and so forth in the session. The object named by this property is also used to display the message &quot;Ready...&quot; when APL is waiting for input.</td>
</tr>
<tr>
<td>Popup</td>
<td>A character vector that specifies the name of a popup menu to be displayed when you click the right mouse button in a Session window.</td>
</tr>
<tr>
<td>Posn</td>
<td>A 2-element numeric vector containing the position of the top-left corner of the session window relative to the top-left corner of the screen. This is reported and set in units specified by the Coord property.</td>
</tr>
<tr>
<td>Size</td>
<td>A 2-element numeric vector containing the height and width of the session window expressed in units specified by the Coord property.</td>
</tr>
</tbody>
</table>
### Property Description

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>State</strong></td>
<td>An integer that specifies the window state (0=normal, 1=minimised, 2=maximised). You may wish to use this property to minimise and later restore the session under program control. If you save your session with State set to 2, your APL session will start off maximised.</td>
</tr>
<tr>
<td><strong>TipObj</strong></td>
<td>Specifies the name of the object in which tips are displayed. Unless you specify TipObj individually for session components, this object will be used to display the tips associated with all of the menu items, buttons, and so forth in the session.</td>
</tr>
<tr>
<td><strong>XRange</strong></td>
<td>See Object Reference</td>
</tr>
<tr>
<td><strong>YRange</strong></td>
<td>See Object Reference</td>
</tr>
</tbody>
</table>

### Special Properties

The following properties of ⎕SE are used internally by Dyalog tools such as SALT. They are not intended nor supported for general use and are not reported by PropList.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>StatusWindow</strong></td>
<td>This read-only property returns a reference to the Status Window. The expression: ⎕SE.⎕WG'StatusWindow'⎕WG'Text' returns the (read-only) contents of the status window.</td>
</tr>
<tr>
<td><strong>Editor</strong></td>
<td>This read-only property returns a reference to the Editor Window. The Editor generates the special events Fix, AfterFix and Format.</td>
</tr>
</tbody>
</table>
Special Events

The following special events are generated by ⎕SE or its child objects. They are used internally by Dyalog tools such as SALT. They are not intended nor supported for general use.

<table>
<thead>
<tr>
<th>Event</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AfterFix</td>
<td>This event is reported by the Editor after it has successfully fixed a new object, or a new version of an object, in the workspace.</td>
</tr>
<tr>
<td>Fix</td>
<td>This event is reported by the Editor when the user attempts to fix an object.</td>
</tr>
<tr>
<td>Format</td>
<td>This event is reported by the Editor when the user attempts to format an object.</td>
</tr>
<tr>
<td>SessionPrint</td>
<td>This event is reported when a value is about to be displayed in the Session window. The default display of the value may be intercepted by a callback function and displayed differently. This event is used by the ]box and ]rows user commands.</td>
</tr>
<tr>
<td>SessionTrace</td>
<td>This event is reported when an expression is executed with trace control. The trace behaviour may be intercepted by a callback function and altered. This event is used by the ]box and ]rows user commands.</td>
</tr>
<tr>
<td>WorkspaceLoaded</td>
<td>This event is generated when a workspace is loaded or upon )CLEAR.</td>
</tr>
</tbody>
</table>
### AfterFix Event 822

**Applies To:** Editor

**Description**

If enabled, this event is reported immediately after the Editor has successfully fixed a new object, or a new version of an object, in the workspace.

You may not nullify or modify the event with a 0-returning callback, nor may you generate the event using \(NQ\), or call it as a method. However, returning 0 from a callback will cause the Edit window to remain open if the user action was Fix and Exit (EP).

The event message reported as the result of \(DQ\), or supplied as the right argument to your callback function, is a 7-element vector as follows:

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>[1]</td>
<td>Object</td>
<td>ref to the Editor object</td>
</tr>
<tr>
<td>[2]</td>
<td>Event</td>
<td>'AfterFix' or 822</td>
</tr>
<tr>
<td>[3]</td>
<td>Contents</td>
<td>the contents of the Edit window, as a vector of character vectors</td>
</tr>
<tr>
<td>[4]</td>
<td>Space</td>
<td>ref to the namespace in which the object will be fixed</td>
</tr>
<tr>
<td>[5]</td>
<td>Old Name</td>
<td>a character vector containing the original name of the object when it was opened by the Editor</td>
</tr>
<tr>
<td>[6]</td>
<td>New Name</td>
<td>a character vector containing the name of the object which was fixed. This is empty if the object is a variable.</td>
</tr>
<tr>
<td>[7]</td>
<td>File Name</td>
<td>a character vector containing the name of the file (if any) associated with the object.</td>
</tr>
</tbody>
</table>
**Fix**  
Event 820

**Applies To:** Editor

**Description**

If enabled, this event is reported when the user attempts to fix an object from the Editor window. It is reported immediately, before the user's action is processed in any way by the Editor.

The default action is to check whether the object has changed. If not, no further action takes place. If the object has changed, the system validates the contents of the Edit window, and either displays an error dialog or fixes a new version of the object in the workspace. If the user action was to fix and exit (EP), the Edit window is closed unless the validation failed.

If the callback function returns 0, the default action is aborted in its entirety (not even the validation takes place) and the Edit window remains open.

You may not generate the event using ⎕NQ, or call it as a method.

The event message reported as the result of ⎕DQ, or supplied as the right argument to your callback function, is a 7-element vector as follows:

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[1]</td>
<td>Object ref to the Editor object</td>
</tr>
<tr>
<td>[2]</td>
<td>Event 'Fix' or 820</td>
</tr>
<tr>
<td>[3]</td>
<td>Contents the contents of the Edit window, as a vector of character vectors</td>
</tr>
<tr>
<td>[4]</td>
<td>Space ref to the namespace in which the object will be fixed</td>
</tr>
<tr>
<td>[5]</td>
<td>Old Name a character vector containing the original name of the object when it was opened by the Editor</td>
</tr>
<tr>
<td>[6]</td>
<td>New Name a character vector containing the new name of the object. This is empty if the object is a variable.</td>
</tr>
<tr>
<td>[7]</td>
<td>File Name a character vector containing the name of the file (if any) associated with the object.</td>
</tr>
</tbody>
</table>

For objects whose names are part of the content of the Edit window, this event is not reported if the name is missing or invalid. Instead the system will display an error dialog box.
Format  

**Applies To:** Editor

**Description**

If enabled, this event is reported when the user attempts to format an object in the Editor window.

If the callback function returns 0, the contents of the Edit window are not reformatted.

You may not generate the event using ⎕NQ, or call it as a method.

The event message reported as the result of ⎕DQ, or supplied as the right argument to your callback function, is a 6-element vector as follows:

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Object</td>
<td>ref to the Editor object</td>
</tr>
<tr>
<td>2</td>
<td>Event</td>
<td>'Format' or 821</td>
</tr>
<tr>
<td>3</td>
<td>Contents</td>
<td>the contents of the Edit window, as a vector of character vectors</td>
</tr>
<tr>
<td>4</td>
<td>Space</td>
<td>ref to the namespace in which the object will be fixed</td>
</tr>
<tr>
<td>5</td>
<td>Old Name</td>
<td>a character vector containing the original name of the object when it was opened by the Editor</td>
</tr>
<tr>
<td>6</td>
<td>New Name</td>
<td>a character vector containing the new name of the object. This is empty if the object is a variable.</td>
</tr>
</tbody>
</table>

SessionPrint  

**Applies To:** Session

**Description**

If enabled, this event is reported when a value is about to be displayed in the Session. It is generated by the display of a variable or the result of a function including system variables and functions. Error messages and output from system commands do not generate this event.
The event message reported as the result of \[DQ\], or supplied as the right argument to your callback function, is a 2-element vector as follows:

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>[1]</td>
<td>Object</td>
<td>ref or character vector</td>
</tr>
<tr>
<td>[2]</td>
<td>Event</td>
<td>'SessionPrint' or 526</td>
</tr>
</tbody>
</table>

The attachment of a callback function intercepts and annuls the normal display of any value.

Note that this event may be extended in future; in particular the number of elements in the event message may be increased, and the event may be generated by some system commands. You should therefore allow for such extensions in any code which refers to SessionPrint.

When the event is generated, the left argument of the callback function contains the value which was about to be displayed. The callback function may display this or any other value, using default output or by assignment to \[.\] If so, this output will be processed normally, without generating a subsequent SessionPrint event. If the callback fails to explicitly display anything, nothing will appear in the Session.

**Example**

```apl
⍕VR ⍕SE.TimeStamp'
∇ VAL TimeStamp EV
[1] ⍕TS VAL
∇

'⍕SE' ⍕WS 'Event' 'SessionPrint' '⍕SE.TimeStamp'

2
2014 9 18 16 20 38 318 2

⍕A
2014 9 18 16 20 44 668 ABCDEFGHIJKLMNOPQRSTUVWXYZ
```

The result (if any) of the callback function is ignored.

You may not disable the event (by setting its action to \[-1\]), nor generate the event using \[NQ\], nor call it as a method.
SessionTrace

Event 527

**Applies To:** Session

**Description**

If enabled, this event is reported when an expression is executed with trace control. See *Language Reference Guide*: *Set Trace*. Error messages and output from system commands do not generate this event.

The event message reported as the result of ⍝DQ, or supplied as the right argument to your callback function, is a 4-element vector as follows:

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Object</td>
<td>ref or character vector</td>
</tr>
<tr>
<td>2</td>
<td>Event</td>
<td>'SessionTrace' or 527</td>
</tr>
<tr>
<td>3</td>
<td>Function</td>
<td>Character vector ('' if none)</td>
</tr>
<tr>
<td>4</td>
<td>Line number</td>
<td>Numeric scalar (0 if none)</td>
</tr>
</tbody>
</table>

The attachment of a callback function intercepts and annuls the normal display of function name, line numbers and any value.

Note that this event may be extended in future; in particular the number of elements in the event message may be increased. You should therefore allow for such extensions in any code which refers to SessionTrace.

When the event is generated, the left argument of the callback function contains the result value of the expression, if any. The callback function may display this or any other value, using default output or by assignment to ⍟. If so, this output will be processed normally, without generating any SessionTrace or SessionPrint events. If the callback fails to explicitly display anything, nothing will appear in the Session.

If the expression has no value, then the callback function will be called monadically. It is therefore required that the callback function is ambivalent (can be called both monadically and dyadically).
Example

```apl
)cs □SE
□SE
   ⍉{VAL}TimeStamp EV
[1]   ⍟□TS(2↑2+EV)
[2]   :If 0≠□NC'VAL'
[3]   ⍟←VAL
[4]   :EndIf
[5]   ⍟←□UCS 13

)cs
#
'□SE'□WS'Event' 'SessionTrace' '□SE.TimeStamp'

∇ Foo
[1]   A just a comment
[2]   global←□A

∇
1 2 □TRACE'Foo'
 Foo
2020 7 3 14 2 37 762  Foo 1
2020 7 3 14 2 37 763  Foo 2 ABCDEFGHIJKLMNOPQRSTUVWXYZ
```

The result (if any) of the callback function is ignored.

You may not disable the event (by setting its action to -1), nor generate the event using □NQ, nor call it as a method.
WorkspaceLoaded  Event 525

Applies To: Session

Description

If enabled, this event is reported when a workspace is loaded or on a clear ws. You may not nullify or modify the event with a 0-returning callback, nor may you generate the event using ⎕NQ, or call it as a method.

The event message reported as the result of ⎕DQ, or supplied as the right argument to your callback function, is a 2-element vector as follows:

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>[1]</td>
<td>Object</td>
<td>ref or character vector</td>
</tr>
<tr>
<td>[2]</td>
<td>Event</td>
<td>'WorkspaceLoaded' or 525</td>
</tr>
</tbody>
</table>

This event is fired immediately after a workspace has been loaded and before the execution of ⎕LX.

The callback function you attach should be defined in ⎕SE.
Configuring the Session

As supplied, your default session will have a menu bar, a tool bar and a status bar. There are many ways in which you may configure this set-up, including the following:

You may select a different APL font or character size.

You may alter the appearance of the menus by changing the Caption properties of the various Menu and MenuItem objects. For example, you may prefer the menus to appear in your own language.

You may alter the structure of the menus. For example, you may wish to create a Search menu directly on the menu bar rather than having Find and Replace as part of the Edit menu.

You may add new Menu and MenuItem objects to the menu bar, or new Button objects to the tool bar, that execute APL functions or expressions for you. You can store the code inside the ⎕SE namespace so that it remains available when you switch from one workspace to another.

You may add other objects to the tool bar to allow you to provide input for your functions or to display output. For example, you may display a Combo object that offers you a selection of names applicable to a particular task.

You may add additional toolbars.

You may remove objects too; for example, you can remove fields from the StatusBar or even delete it entirely. Indeed, you may dispense with the menu bar and/or tool bar as well.

This section illustrates how you can configure your session using worked examples. The examples are by no means exhaustive, but are designed to demonstrate the principles. Please note that the structure and names of the objects used in these examples may not be identical to your default session as supplied. Before you attempt to change your session, please check the structure and the object names using ⎕WN and ⎕WG. The supplied session was created using the function BUILD_SESSION in the workspace BUILDSE. If you wish to make substantial changes to your session, you may find it most convenient to edit the functions in this workspace, re-run BUILD_SESSION, and then save it.

Please note that these examples assume that Expose Session Properties is enabled.
Changing the Font

The APL session font is defined by the Font property of ⎕SE. To change the font permanently, you should select a different Font and/or size of Font using the combo and spinner boxes on the Session toolbar, and save your Session.

Classic Edition is distributed with bitmap fonts suitable for use on your screen, and TrueType fonts for your printer. You can use the TrueType font on the screen, but it is less attractive than the bitmap fonts at low resolutions. The bitmap fonts come in two sizes (16 x 8 and 22 x 11) and two weights (normal and bold). You may select other sizes, so long as the height is a multiple of 16 or 22. The scaling is performed automatically by Windows.

Changing Menu Appearance

The name of the Session MenuBar is ‘⎕SE.mb’. To simplify the specification of object names, we will first change space to the MenuBar itself:

```apl
)CS ⎕SE.mb
⎕SE.mb
```

The names of the Menu objects owned by the MenuBar are given by the expression:

```apl
'Menu' ⎕WN '''
file edit view windows session log action options tools threads help
```

The current caption on the file menu is:

```apl
file.Caption
&File
```

To change the Caption to Workspace:

```apl
file.Caption←'Workspace'
```

To change the colour of the New option in the File menu to red:

```apl
file.clear.FCol←255 0 0
```
Reorganising the Menu Structure

This example shows how you may alter the structure of the session menus by adding a Search menu to the menu bar to provide access to the Find and Find/Replace dialog boxes and removing these options from the Edit menu.

To simplify the process, we will first change space into the MenuBar object itself:

```
)CS ⎕SE.mb
⎕SE.mb
```

Then we can begin by adding the Search menu. You can specify where the new menu is to be added using its Posn property. In this case, Search will be added at position 3 (after Edit).

```
'search'⎕WC 'Menu' '&Search' 3
```

Next we will remove the Find and Replace MenuItem objects from the Edit menu. Their names can be obtained from ⎕WN:

```
'MenuItem'⎕WN'edit'
edit.prev edit.next edit.clear edit.copy edit.paste
edit.find edit.replace
```

It is worth noting that these MenuItems perform their actions because their Event property is set to execute the system operations [Find] and [Replace] respectively when they are selected.

```
edit.find.Event
Select [Find]
edit.replace.Event
Select [Replace]
```

The following statement removes them from the Edit menu:

```
⎕EX¨'edit.find' 'edit.replace'
```

and the following statements add them to the Search menu:

```
'search.find' ⎕WC 'MenuItem' '&Find'
 ('Event' 'Select' '[Find]')
'search.replace' ⎕WC 'MenuItem' '&Replace'
 ('Event' 'Select' '[Replace]')
```
Adding your own MenuItem

This example shows how you can add a menu item that executes an APL expression. In this case we will do something very simple; namely add a Time option to the Tools menu which will execute ⎕TS. Notice that the statement also defines a Hint. This will be displayed when you select the option, prior to releasing the mouse button to action it.

Once again, we will start by changing space into the Tools menu itself

)CS ⎕SE.mb.tools ⎕SE.mb.tools

Then we will define a new MenuItem to perform the action we require:

'ts'⎕WC'MenuItem' '&Time'
   ('Event' 'Select' '⎕TS')
   ('Hint' 'Display Timestamp')

The ⎕ symbol is very important and distinguishes an expression to be executed immediately, as in this case, from a callback function. The resulting Tools menu now appears as follows:

A customised Tools menu

Selecting Time produces the following output in the session:

2007 12 10 17 10 2 0
Adding your own Tool Button

This example shows how you can add a button to the session tool bar that executes an APL function called \texttt{XREF}.

\texttt{XREF} analyses the function whose name is under the cursor, listing the names of the other functions that it calls in a Form.

\begin{verbatim}
∇ XREF;REFS;FN
  [1]  :If 0<⍴FN←'⎕SE'⎕WG'CurObj'
  [2]  :AndIf 3=⎕NC FN
  [3]     REFS←REFS('⎕SE'⎕WG'CurSpace'),'.',FN
  [4]     REFS←(⁺REFS)~''
  [5]     REFS←(3.1=⎕NC REFS)/REFS
  [6]     REFS←REFS~⊂FN
  [7]     :If 0<⍴REFS
  [8]       'F'⎕WC'Form'('Functions called by ',FN)
  [9]       F.FontObj←⎕SE.FontObj
  [10]      'F.L'⎕WC'List'REFS(0 0)(100 100)
  [12]     :EndIf
∇
\end{verbatim}

\texttt{XREF[1]} gets the value of the \texttt{CurObj} property of \texttt{⎕SE} which reports the name under the cursor.

\texttt{XREF[3]} prefixes this name by its pathname which comes from the \texttt{CurSpace} property which reports the user's current namespace.

To make this function available from a Session tool button, we need to do a number of things. Firstly, we must install the function in \texttt{⎕SE} so that it is always there, regardless of the current active workspace. This is easily achieved using the Explorer or \texttt{⎕NS}.

\texttt{'⎕SE' ⎕NS 'XREF'}

Next we will add a new button to the tool bar in the \texttt{Tools CoolBand}. Ideally we would use a suitable bitmap, but to simplify the example, we will use a standard text button:

\begin{verbatim}
)CS ⎕SE.cbttop.bandtb3.tb
⎕SE.cbttop.bandtb3.tb
  'xref' ⎕WC 'Button' 'XREF'
  'xref' ⎕WS 'Event' 'Select' '⎕SE.XREF'
\end{verbatim}

\textbf{Adding a tool button}

All that remains is to save the new Session.
Session Initialisation

Introduction

Each time Dyalog starts it loads and executes an initialisation file whose name is defined by the DyalogStartup parameter. If this is undefined, the default file is named startup.dyalog in the Dyalog directory. Among other tasks, the code defined in startup.dyalog also performs Session initialisation.

Implementation

Code to be installed in ⎕SE is specified in APL source code files contained in Session initialisation directories identified by the DyalogStartupSE parameter. If this parameter is not specified, the default is a directory named StartupSession located in three standard locations as described below.

Only content stored in files matching the wildcard patterns *.dyalog and *.apl? will be loaded. All such files must be appropriate for ⎕FIX.

For each sub-directory in a Session initialisation directory, a corresponding namespace is created in ⎕SE, and any source code files in these sub-directories will be fixed in their respective corresponding namespaces. There is currently no support for additional subdirectories inside these subdirectories, although this feature is planned.

The Session initialisation directories are processed in order and code defined in each directory will replace code with the same name defined previously. In effect, this means that user-supplied content can replace content supplied by Dyalog Ltd. and version-specific content can replace version-agnostic content.

Default Session Initialisation Directories

If the DyalogStartupSE parameter is undefined, APL looks for Session initialisation directories named StartupSession in the following three locations, and processes them in that order:

1. The Dyalog installation directory (which contains the dyalog executable)
2. A version-agnostic sub-directory in the user directory (the standard directory for user-related Dyalog APL files)
3. A version-specific sub-directory in the user directory, whose name is derived as described below.
Under Windows these might be:

1. C:\Program Files\Dyalog\Dyalog APL-64 18.0 Unicode
2. C:\Users\Pete\Documents\Dyalog APL Files
3. C:\Users\Pete\Documents\Dyalog APL-64 18.0 Unicode Files

The version-specific name is:

Dyalog APL{bit} {version} {edition}

where:

- {bit} is "-64" if 64-bit version, otherwise nothing
- {version} is the main and secondary version numbers of dyalog.exe separated by ".".
- {edition} is "Unicode" for the Unicode Edition, otherwise nothing
User Commands

Dyadlog APL includes a mechanism to define User Commands.

User commands are developer tools, written in APL, which can be executed without having to explicitly copy code into your workspace and/or save it in every workspace in which you want to use it.

A User Command is a name prefixed by a closing square bracket, which may be niladic or take an argument. A User Command executes APL code that is typically stored somewhere outside the current active workspace.

By default, the existing SPICE command processor is hooked up to the user command mechanism, and a number of new SPICE commands have been added. For example:

```
]display 'hello' ('world')
```

The implementation of User Commands is very simple: If a line of input begins with a closing square bracket (]), and there exists a function by the name ⎕SE.UCMD, then the interpreter will call that function, passing the input line (without the bracket) as the right argument.

To add a user command, drop a new Spice command file in the folder SALT\Spice.
Chapter 1: The APL Environment

File Explorer Integration

File Associations

During installation, Dyalog establishes the following file associations:

<table>
<thead>
<tr>
<th>Type</th>
<th>File Extension</th>
<th>Application</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shell Scripts</td>
<td>.apls</td>
<td>Dyalog script execution engine via Windows Power Shell</td>
</tr>
<tr>
<td>Sources</td>
<td>.aplc, .aplfl, .apli, .apln, .aplo, .dyalog</td>
<td>Dyalog Editor</td>
</tr>
<tr>
<td>Configuration</td>
<td>.dcfg</td>
<td>Dyalog Editor</td>
</tr>
<tr>
<td>SALT apps</td>
<td>.dyapp</td>
<td>Dyalog</td>
</tr>
<tr>
<td>Workspaces</td>
<td>.dws</td>
<td>Dyalog</td>
</tr>
</tbody>
</table>

When you double-click on a file with one of the above extensions, the file is opened with the corresponding application.

In addition, two items are added to the Windows Explorer context menu for directories, namely Load with Dyalog and Run with Dyalog. Both these items start Dyalog and attempt to import code from the corresponding directory using Link. The Run with Dyalog option also calls the function named Run if it exists. See Load Parameter on page 1.

For more information about Link, see https://dyalog.github.io/link/3.0/.

The ]fileAssociations user command may be employed to alter these settings. For details, enter:

]fileassociations -?

Browsing Workspaces and Source Files

(Unicode Edition Only)

You can browse the contents of workspaces and Dyalog source files using the preview pane of Windows File Explorer. The following example show what you see in the preview pane when you select the supplied workspace ddb.dws.
When you move the cursor to the next workspace in the list, dfns.dws, the preview pane is immediately updated to show its contents.
If you open the Fns/Ops node and click on a function name, the function is displayed. The next picture shows the function assign.
You can also browse Dyalog source files. The following picture shows what you see when you select the fileUtils.dyalog file.

Note that you may only view workspace objects and scripts in the preview pane, it is not possible to edit them in the preview pane.
Editing Dyalog Source Files

You may edit a source file from File Explorer by first selecting the source file and then choosing Edit from the File Explorer context menu.

This brings up the standard Dyalog Editor, in a stand-alone window, just as it would appear if undocked from the Session, as shown in the next picture.
Index

.NET Classes
exploring 94

A
ActiveXControl object 66
aedit User Command 37
AfterFix 185
aligning comments 133
APL fonts 193
Array Editor 37, 61
assemblies
exploring 94
auto_pw parameter 31
AutoComplete 30

B
backtick keyboard 9
Browse .NET Assembly dialog box 95

C
chart wizard 61
class constructor 98
Classes
browsing 77
Classic Dyalog mode 154
multiple trace windows 162
single trace window 163
Classic Edition 45, 64
ClassicMode parameter 116
ClassicModeSavePosition parameter 116
CloseAll system operation 46
collapsing outlines 130, 135, 141
compiler errors 129
configuring the session 192
Constructors folder 98
context menu 26
Create (session event) 180
CurObj (session property) 5, 181
CurPos (session property) 181
Current Object 5
CurSpace (session property) 181

D
Debugging Threads 168
default wx parameter 51
deleting lines 29
Docking 21
DyalogStartSE Parameter 197
DyalogStartup Parameter 197

E
edit_cols parameter 113, 116
edit_first_x parameter 113, 116
edit_first_y parameter 113, 116
edit_offset_x parameter 113, 116
edit_offset_y parameter 113, 116
edit_rows parameter 113, 116
editor
aligning comments 133
class treeview 129, 142
collapsing outlines 130
compiler errors 129
edit menu 124
editing classes 140
expanding outlines 130
file menu 120
function line numbers 129
invoking 111
outlining 130, 135
refactor menu 128
sections 143
selecting text 117
syntax menu 126
toolbar 118
trace, stop and monitor 134
using 131
view menu 129
windows menu 127
endsection statement 137, 143
Enums 93
Event (session property) 182
Event Sets 92
Events
  AfterFix 185
  Fix 186
  Format 187
  SessionPrint 187
  SessionTrace 189
  WorkspaceLoaded 191
executing expressions 30
execution (tracing) 160
expanding outlines 130, 135, 141

L
language bar 27
line numbers 129-131
Log (session property) 181

M
Metadata 94, 96
Methods folder 101
monitor 134
mouse
  using in session 5

N
NET classes 94
Net Metadata 83
New method 98

O
Object CoClasses 87
Object Properties
  COM Properties tab 109
  Monitor tab 108
  Net Properties tab 110
  Properties tab 106
  Value tab 107
Objects 89
OLEClient object 83, 86
OLEServer object 66
outlining 130, 135

P
page width 31
Popup (session property) 182
Posn (session property) 182
private 98
Properties folder 99
PropertyExposeRoot parameter 51
PropertyExposeSE parameter 51

K
keyboard shortcuts 2, 11
Index

R
registry keyboard 3
replace 146

S
section statement 137, 143
selecting text 117
session
configuring 4, 192
deleting lines 29
file menu 41
help menu 53
initialisation 197
options menu 50
popup menu 55
session menu 47
status bar 64
status field styles 64
threads menu 52
tools menu 51
value tips 33
session action menu 48
session colour scheme 17
session initialisation 197
session log 19, 29
session log menu 48
session menubar 41
action menu 48
edit menu 44
file Menu 41
help menu 53
log menu 48
options menu 50
session menu 47
threads menu 52
tools menu 51
view menu 46
windows menu 46
session object 4, 20, 47, 180
session statusfields 65
session toolbars 59
edit tools 62
object tools 61
session tools 63
tools tools 62
workspace tools 60
session_file parameter 4, 20, 180
SessionOnTop parameter 116
SessionPrint 180, 187
SessionTrace 189
Show trace stack on error 153
Size (session property) 182
SPICE 199
State (session property) 183
Status window 21, 66
stop 134
system operations 4, 47, 194

T
Threads Tool 164
TipObj (session property) 183
trace 134
trace tools 155
Trace_on_error parameter 153
tracer
automatic trace 153
break-points 161
Classic Dyalog mode 154
controlling execution 160
invoking 153
naked trace 153
tracing an expression 153
treeview 129, 142
Type Libraries 74, 83

U
underscored characters 11
Unicode Edition 64
User Commands 199
aedit 37

V
value tips 33
view menu
editor 129
session) 46
Visual Styles 59
W

white space  134
WorkspaceLoaded  180, 191