The Configuration Dialog Box
The Configuration dialog box is displayed from the Session by selecting Configure from the Options menu. It presents many of the interpreter's configuration parameters, grouped into tabs; changing a setting and clicking OK updates the corresponding parameter. Each tab is described in its own section.
Some tabs are present only in the Unicode edition or only in the Classic edition, as noted in their headings.
General Tab

| Label | Parameter | Description |
|---|---|---|
| Recently used file list size | File_Stack_Size | Specifies the number of the most recently used workspaces displayed in the File menu |
| Underline URLs and links | URLHighlight | Specifies whether URLs and links are highlighted in Session and Edit windows |
| Display Value Tips | Enabled | Specifies whether Value Tips are enabled |
| Display Value Tips after | Delay | Specifies the delay before APL displays a Value Tip |
| Colour Scheme | ColourScheme | Specifies the colour scheme used to display Value Tips |
| Enable DPI Scaling of the interpreter and development environment | AutoDPI | Enables or disables DPI scaling for the APL Session |
| Enable DPI scaling of GUI application | Dyalog_Pixel_Type | Determines whether Coord 'Pixel' is treated as ScaledPixel or RealPixel |
| Configuration saved in | IniFile | Specifies the full pathname of the registry folder used by APL |
Unicode Input Tab (Unicode)
Unicode Edition can optionally select your APL keyboard each time you start APL. To choose this option, select one of your installed APL keyboards, enable the Activate selected keyboard checkbox, then click OK.

| Label | Parameter | Description |
|---|---|---|
| Activate selected keyboard | InitialKeyboardLayoutInUse | If checked, the specified APL keyboard is activated on start-up |
| Show keyboards for all Languages | InitialKeyboardLayoutShowAll | If checked, all installed keyboards are displayed. Otherwise, only Dyalog keyboards are shown |
| Keyboard | InitialKeyboardLayout | The APL keyboard to be selected |
| Configure Layout | Displays the Input Method Editor Properties dialog box |
Input Method Editor Properties Dialog Box

| Label | Parameter | Description |
|---|---|---|
| Use Ctrl+X,C,V for clipboard | UseXCV | Specifies whether the commonly used keystrokes for copy, cut, and paste are recognised as such |
| Enable Backtick Keyboard introducer | Enables the Backtick keyboard, in which the backtick character introduces APL glyphs. See Backtick Keyboard | |
| Enable Overstrikes | ResolveOverstrikes | 1 = enable overstrikes. 0 = disable overstrikes |
| Overstrikes do not require the OS introducer key | 1 = IME identifies overstrike operation automatically 0 = IME requires the <OS> key (default Ctrl+Bksp) to signal an overstrike operation | |
| Use Overstrike popup | OverstrikesPopup | 1 = enable the overstrike popup. 0 = disable the overstrike popup |
Input Tab (Classic)

| Label | Parameter | Description |
|---|---|---|
| Input table search path | APLKeys | A list of directories to be searched for the specified input table |
| Input table file | APLK | The name of the input table file (.DIN) |
Output Tab (Classic)

| Label | Parameter | Description |
|---|---|---|
| Output table search path | APLTrans | A list of directories to be searched for the specified output table |
| Output table file | APLT | The name of the output table file (.DOT) |
Keyboard Shortcuts Tab

To alter the keystroke associated with a particular action, simply select the action required and press the keystroke. For example, to change the keystroke associated with the action <UA> (undo all changes) from (None) to Ctrl+Shift+u, simply select the corresponding row in the list and press Ctrl+Shift+u. If Confirm before Overwrite is checked, you will be prompted to confirm or cancel before each and every change is written back to the registry.
Clicking on the column headings sorts on that column; shift and mouse click will sort in reverse order.
Saved Responses Tab

The Saved Responses tab of the Configuration dialog is used to remove preferences that the user has previously established.
In this example, the user has at some point chosen to save a text file with a .h extension as text in the workspace and, by checking the option Save this response for all files with a ".h" extension, saved this as a preference for all such text files. Similarly, the user has checked the option Do not show this message again when responding to the warning dialog Saving as text will ....
If the user wants to reverse these decisions, even temporarily, it is necessary to select the corresponding option /preference name(s) and click Delete. The names are intended to be self-explanatory and are not listed here.


Workspace Tab

| Label | Parameter | Description |
|---|---|---|
| Workspace search path | WSPath | A list of directories to be searched for the specified workspace when the user executes )LOAD |
| Maximum workspace size | MaxWS | The maximum size of the workspace |
Help/DMX Tab

| Label | Parameter | Description |
|---|---|---|
| DMX messages should go to | DMXOutputOnError | If checked, these boxes cause APL to display ⎕DMX messages in the corresponding window(s) |
| Use Microsoft's documentation centre for non-Dyalog topics | UseExternalHelpURL | If this option is checked, APL will look for help for external objects at Microsoft's documentation centre, which is identified by the specified URL |
| URL | ExternalHelpURL | The URL for the documentation centre |
Windows Tab

| Label | Parameter | Description |
|---|---|---|
| Width | Edit_Cols | The maximum number of rows displayed in a new edit window |
| Height | Edit_Rows | The maximum number of columns displayed in a new edit window |
| X Pos | Edit_First_X | The initial horizontal position in characters of the first edit window |
| Y Pos | Edit_First_Y | The initial vertical position in characters of the first edit window |
| X Offset | Edit_Offset_X | The initial horizontal position in characters of the second and subsequent edit windows relative to the previous one |
| Y Offset | Edit_Offset_Y | The initial vertical position in characters of the second and subsequent edit windows relative to the previous one |
| Label | Parameter | Description |
|---|---|---|
| X Pos | Trace_First_X | The initial horizontal position in characters of the first trace window |
| Y Pos | Trace_First_Y | The initial vertical position in characters of the first trace window |
| X Offset | Trace_Offset_X | The initial horizontal position in characters of the second and subsequent trace windows relative to the previous one |
| Y Offset | Trace_Offset_Y | The initial vertical position in characters of the second and subsequent trace windows relative to the previous one |
| Label | Parameter | Description |
|---|---|---|
| Width | SM_Cols | The width of the ⎕SM window |
| Height | SM_Rows | The height of the ⎕SM window |
Session Tab

| Label | Parameter | Description |
|---|---|---|
⎕IO | Default_IO | The default value of ⎕IO in a clear ws |
⎕ML | Default_ML | The default value of ⎕ML in a clear ws |
⎕PP | Default_PP | The default value of ⎕PP in a clear ws |
⎕RTL | Default_RTL | The default value of ⎕RTL in a clear ws |
⎕DIV | Default_DIV | The default value of ⎕DIV in a clear ws |
⎕WX | Default_WX | The default value of ⎕WX in a clear ws |
| Auto PW | Auto_PW | If checked, the value of ⎕PW is dynamic and depends on the width of the Session Window |
| Input buffer size | Input_Size | The size of the buffer used to store marked lines (lines awaiting execution) in the Session |
| History size | History_Size | The size of the buffer used to store previously entered (input) lines in the Session |
| PFKey buffer size | PFKey_Size | The size of the buffer used to store PFKey definitions ( ⎕PFKEY ) |
| Confirm on Deletion from Session log | Confirm_Session_Delete | Specifies whether you are prompted to confirm the deletion of a line from the Session (and Session log) |
| Session log size | Log_Size | The size of the Session log buffer |
| Session file | Session_File | The name of the Session file in which the definition of your session ( ⎕SE ) is stored |
| Use log file | Log_File_InUse | Specifies whether the Session log is saved in a session log file |
| Use log file | Log_File | The full pathname of the Session log file |
| Multiline Input | Dyalog_LineEditor_Mode | Specifies whether multi-line input is enabled in the Session |
The size-related values in the Session tab are specified as an integer value followed by one of K, M, G, T, P, or E. Where no character is included, the default is K (kilobytes).
Trace/Edit Tab

| Label | Parameter | Description |
|---|---|---|
| Allow floating edit windows | DockableEditWindows | Allows individual Edit windows to be undocked from (and re-docked in) the main Edit window |
| Show status bars | StatusOnEdit | Specifies whether status bars are displayed along the bottom of individual Edit windows |
| Show tool bars | ToolBarsOnEdit | Specifies whether tool bars are displayed along the top of individual Edit windows |
| Show trace stack on error | Trace_On_Error | Specifies whether the Tracer is automatically invoked when an error or stop occurs in a defined function |
| Allow search to wrap | WrapSearch | Specifies whether Search/Replace in the Editor stops at the top or bottom of the text, or continues from the start or end as appropriate |
| Show message box if text wraps | WrapSearchMsgBox | Specifies whether a message box is displayed to inform the user when the search wraps |
| Warn if trace stack bigger than | Trace_Level_Warn | Specifies the maximum stack size for automatic deployment of the Tracer |
| Confirm edit window close on Close | Confirm_Close | Specifies whether a confirmation dialog box is displayed if the user alters the contents of an edit window then closes it without saving |
| Confirm edit window close on Edit (and Fix) | Confirm_Fix | Specifies whether a confirmation dialog box is displayed if the user alters the contents of an edit window then saves it using Fix or Exit |
| Confirm edit window close on Abort | Confirm_Abort | Specifies whether a confirmation dialog box is displayed if the user alters the contents of an edit window then aborts the edit session |
| Autoformat functions | AutoFormat | Selects automatic indentation for control structures when function is opened for editing |
| Autoindent | AutoIndent | Selects semi-automatic indentation for control structures while editing |
| Double-click to Edit | DoubleClickEdit | Specifies whether double-clicking over a name invokes the editor |
| Skip blank lines when tracing | SkipLines | If enabled, this causes the Tracer to automatically skip blank lines |
| Skip comment lines when tracing | SkipLines | If enabled, this causes the Tracer to automatically skip comment lines |
| Skip locals lines when tracing | SkipLines | If enabled, this causes the Tracer to automatically skip locals lines |
| Limit tracer display to current function in script | AddClassHeaders | When Tracing the execution of a function in a script, the Tracer displays either just the first line of the script and the function in question (option enabled), or the entire script (option disabled) |
| Paste text as Unicode (Classic Edition only) | UnicodeToClipboard | Specifies whether text transferred to and from the Windows clipboard is to be treated as Unicode |
| Tab stops every | TabStops | The number of spaces inserted by pressing Tab in an edit window |
| Exit and fix ... | InitFullScriptSusp | See Fixing Scripts |
| If not ... | InitFullScriptNormal | See Fixing Scripts |
Fixing Scripts
When using the Editor to edit a script such as a Class or Namespace you can specify whether, when you Fix the script and Exit the Editor, just the functions in the script are re-fixed, or whether the whole script is re-executed, thereby re-initialising any Fields or variables defined within.
These two actions always appear in the Editor File menu, but you can specify which is associated with the <EP> Esc key by selecting the appropriate option in the drop-downs labelled:
- Exit and save changes <EP> in a suspended class or namespace should fix:
- If not suspended fix:
In both cases, you can select either Only Functions or Everything.
The label for the corresponding items on the Editor File menu (see The File Menu (editing a script)) will change according to which behaviour applies. If you specify a keystroke for <S1> in the Keyboard Shortcuts tab, this will be associated with the unselected action.
Auto Complete Tab

To enter values in the OK Key and Cancel Key fields, click on the field with the mouse and then press the desired keystroke.
| Label | Parameter | Description |
|---|---|---|
| Use Auto Complete | Enabled | Specifies whether Auto Completion is enabled |
| Make suggestions after | PrefixSize | Specifies the number of characters you must enter before Auto Completion begins to make suggestions |
| Delay completion for | KeyboardInputDelay | Specifies the delay in milliseconds before Auto Completion begins to make suggestions |
| Suggest up to | Rows | Specifies the maximum number of rows (height) in the AutoComplete pop-up suggestions box |
| Show up to | Cols | Specifies the maximum number of columns (width) in the AutoComplete pop-up suggestion box |
| Keep History | History | Specifies whether AutoComplete maintains a list of previous AutoCompletions |
| History Length | HistorySize | Specifies the number of previous AutoCompletions that are maintained |
| Include filenames | ShowFiles | Specifies whether AutoCompletion suggests directory and file names for )LOAD, )COPY, and )DROP system commands |
| OK Key | CompleteKey1 CompleteKey2 | Specifies two possible keys that can be used to select the current option from the Auto Complete suggestion box |
| Cancel Key | CancelKey1 CancelKey2 | Specifies two possible keys that can be used to cancel (hide) the Auto Complete suggestion box |
| Common Key | CommonKey1 | Specifies the key that will auto-complete the common prefix |
SALT Tab
SALT is the Simple APL Library Toolkit, a simple source code management system for Classes and script-based Namespaces. SPICE uses SALT to manage development tools that "plug in" to the Dyalog session.

| Label | Parameter | Description |
|---|---|---|
| Enable Salt | AddSALT | Specifies whether SALT is enabled |
| Compare command line: | CompareCMD | The command line for a third-party file comparison tool to be used to compare two versions of a file |
| Editor command line: | Editor | Name of the program to be used to edit script files (default "Notepad") |
| Source folders: | SourceFolder | Sets the SALT working directory; a list of folders to be searched for source code. Include "." on a separate line to include source files from the current working directory |
User Commands Tab

This page is used to specify and organise a list of folders that contain user command files. When you issue a user command, these folders will be searched for the source of the command in the order in which they appear in this list.
| Label | Parameter | Description |
|---|---|---|
| Source Folders | SALT\CommandFolder | Use this field to add folders to the list of folders that will be searched for User Commands |
Object Syntax Tab

The Object Syntax tab of the Configuration dialog is used to set your default preferences for Object Syntax. Use Options/Object Syntax to change the settings for the current workspace.
| Label | Parameter | Description |
|---|---|---|
| Expose properties of GUI Namespaces | Default_WX | Specifies the value of ⎕WX in a clear workspace |
| Expose properties of Root | PropertyExposeRoot | Specifies whether the names of properties, methods, and events of the Root object are exposed |
| Expose properties of Session Namespace | PropertyExposeSE | Specifies whether the names of properties, methods, and events of the Session object are exposed |